none
WinPE USB reboots RRS feed

  • Question

  • Hello,

    Trying to boot from USB into WinPE. Prepared the key with diskpart, used copype.cmd to copy the files and copied the litetouch_x64.wim from the deployment share to the sources folder on the key. It boots ok, but the Litetouch vbs never launches, instead the pc just reboots.

    If I hit F8 I get both IP and can confirm local disk is visible.

    Any ideas what might be wrong. What log file can i check.

    thanks


    • Edited by IUSR345369 Thursday, May 1, 2014 10:51 PM
    Thursday, May 1, 2014 10:50 PM

All replies

  • The easy way to do it is, prepare the USB with diskpart, extract the LiteTouch_x64.ISO and copy the contents to the root of the USB. Your way is booting to the WinPE boot.wim, not the litetouch_x64.wim.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Friday, May 2, 2014 1:37 AM
  • I've had this issue before, moving the litetouch_x64.wim alone isn't enough.

    In MDT ensure you generate an ISO also, I then format the USB drive and use 7zip to extract the whole contents of the ISO onto the USB. That ensures that the .wim and all other dependencies are also transferred.

    That is also how I make any Microsoft Bootable Media not just WinPE.

    Friday, May 2, 2014 2:00 AM
  • Just to be clear - I dont want to create a totally offline USB build. I just want to have a USB key that boots and then runs the install from the deployment share, rather than having the applications and full image WIM on the USB stick. Does that affect the procedures above.
    Friday, May 2, 2014 4:25 AM
  • This is for a bootable USB, not offline media. Offline media is a much more in-depth procedure. You are just taking the contents of the boot disk and moving them to the USB. Make sure you create your boot disks in the deployment share, extract the contents, and move them to the root of your diskparted USB stick.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Friday, May 2, 2014 4:28 AM
  • Thanks. Let me give it a shot now and report back.
    Friday, May 2, 2014 4:36 AM
  • Its still not working. 

    I get to the WinPE boot screen, a command prompt flashes up and disappears. then, 15 seconds or so and a reboot. Again, IP is ok and volume is visible.

    How do I troubleshoot this? Log file locations?

    I did attempt to regenerate the ISO but it said no need as hashes matched.

    any ideas?

    Friday, May 2, 2014 5:55 AM
  • PS. I noticed in the unattend.xml in the root of the X drive it was calling X:\Deploy\Scripts\LiteTouch.wsf - surely that should be referencing the deployment share? Do I need to modify it
    Friday, May 2, 2014 5:58 AM
  • PS. I just checked the bootstrap.ini on the share are the DeployRoot is set to network share, userdomain ID and password are correct


    Friday, May 2, 2014 6:05 AM
  • No the deployment share is mounted as X: it is normal

    Are you sure your customsettings.ini file is correct? Do you deploy correctly from PXE?

    Friday, May 2, 2014 2:05 PM
  • If you are sure about your rule file, boostrap, task sequences and so on, i would regenerate the boot file

    1) In the MDT Deployment Workbench MMC, right click the deployment share and select “Properties”.
    2) On the “Windows PE x86 Settings” and/or “Windows PE X64 Settings” tabs, ensure that you have checked “Generate a Lite Touch bootable ISO image”. 
    3) On the “Windows PE x86 Components” and/or “Windows PE x64 Components” tabs, ensure that, at minimum the check boxes to include all network drivers and mass storage drivers are checked. 
    3) Click OK.
    4) Right click the deployment share and select “Update Deployment Share” and complete the update wizard. 

    Then burn the ISO to your USB drive, this is the method i use: http://scriptimus.wordpress.com/2011/06/21/mdt-2010-create-a-lite-touch-deployment-usb-drive-again/


    • Edited by ReMark-IT Friday, May 2, 2014 2:15 PM
    Friday, May 2, 2014 2:14 PM
  • I dont have PXE configured currently. I have also recreated the boot files several times. Drivers are ok as I have an IP and I can see the volume. In addition. If I map the deployment share manually and run litetouch.vbs from there, The wizard starts, the task sequences are displayed and I can launch a build.

    The entire bootstrap.ini contents (Details shielded)

    [Settings]
    Priority=Default

    [Default]
    DeployRoot=\\MyComputerHost\DeploymentShare$
    SkipBDDWelcome=YES
    UserDomain=MyDomain
    UserID=MyUserName  
    UserPassword=Password

    ------------------------

    CustomSettings.ini:

    [Settings]
    Priority=Default
    Properties=MyCustomProperty

    [Default]
    OSInstall=Y

    XResolution=1
    YResolution=1
    BitsPerPel=32

    SkipApplications=NO
    SkipAppsOnUpgrade=NO

    Applications001={effa179c-7075-4732-848a-1155584628e0}
    Applications002={51667de9-e261-4967-8541-cedffc094783}
    Applications003={ab25a91d-b895-4b44-ac86-f4f95c82c118}

    SkipCapture=NO
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipDomainMembership=NO
    MachineObjectOU=OU=foobar
    SkipComputerBackup=YES
    SkipUserData=YES
    SkipBitLocker=YES
    SkipLocaleSelection=YES
    UserLocale=en-GB
    SystemLocale=en-GB
    UILanguage=en-GB
    KeyboardLocale=1811:00001811
    SkipTimeZone=YES
    TimeZoneName=GMT Standard Time
    TimeZone=085
    SkipSummary=Yes

    Friday, May 2, 2014 2:41 PM
  • If this occurs only on your test machine, try cleaning the hard drive with diskpart  (there could be issues with remaining files from a previous tasksequence).

    While inside winpe press F8 to open a command prompt and run diskpart, select disk 0, clean.

    You can also check for log files from there (after F8 in WinPe)

    The deployment logs can be found in the following location


    x:\minint\smsosd\osdlogs

    Friday, May 2, 2014 3:07 PM
  • I thought it might have been that but even after the disk part, no success.

    In addition, the minint folder path you mention does not exist on the root of X - just Deploy, Program Files, Users,Windows and unattend.xml

    Friday, May 2, 2014 3:31 PM
  • Hi,

    Does anybody have any more ideas on this one? As I mentioned above, I do not have the logs described above. It is a bit of a mystery as to what is happening.

    Monday, May 5, 2014 2:52 PM
  • When you format the USB drive are you using fat32?

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, May 5, 2014 5:12 PM
  • I think Im using NTFS. It gets to winpe and I can see the solution accelerator background?
    • Edited by IUSR345369 Monday, May 5, 2014 5:16 PM
    Monday, May 5, 2014 5:16 PM
  • So it appears that you were able to create a USB key, and boot into WinPE, however after you get the background WinPE bitmap and mouse, the machine displays the cmd.exe window and reboots.

    Just to be precise here, MDT in LItetouchPE_x86.wim will never launch the litetouch.vbs script, instead it will launch the litetouch.wsf script. Litetouch.vbs is for the full OS only.

    It is entirely possible that Litetouch.wsf is crashing somewhere in your script. This can typically happen if you have miss-matched scripts from various MDT versions. (verify litetouch.wsf, ztiutility.vbs and ztidiskutility.vbs to ensure they have the same version numbers).

    My recommendation is that once WinPE has launched, press F8, this will prevent the machine from rebooting.

    Then run the following command:

    cscript.exe x:\deploy\scripts\litetouch.wsf /debug:true /debugcapture

    Either the script will continue with no error, or it will crash, and we can find out where the error is.

    post the error if you still need help.


    Keith Garner - keithga.wordpress.com


    Monday, May 5, 2014 6:03 PM
    Moderator
  • Hi Keith.

    Thank you, thats what I was looking for. FYI, there was no VBS as per your command above, just LiteTouch.wsf

    The the wizard has now loaded when I ran the command! So my question is.. why isnt this happening/loading automatically, why isnt it launching the script itself?

    Tuesday, May 6, 2014 7:11 AM
  • Hi guys,

    still not clear why this script is not launching automatically and winpe is rebooting unless I hit F8 and do a manual cscript on litetouch.wsf - (temporarily unmarking as answer just to get little attention for this little extended query :) )


    • Edited by IUSR345369 Wednesday, May 7, 2014 11:56 AM
    Wednesday, May 7, 2014 8:25 AM
  • Runnin the litetouch.wsf till the end of the Install phase should reveal some error in the cmd.exe window.

    If you are not getting *any* errors, then I don't understand what is going on here, we are missing something. Did you modify the litetouch image in other ways? Then I would crack open TaskMgr.exe to see what is going on in the background.


    Keith Garner - keithga.wordpress.com

    Thursday, May 8, 2014 6:18 AM
    Moderator
  • I'm having the same problem as you are.  If I unplug the network cable I get an error about not being able to contact the deployment share.  When I plug the network cable back in and retry things work.   If I run the command to do the debug that was provided, things work.   If I don't do anything at all it just keeps rebooting after sitting on the splash screen for about 2 or 3 minutes.

    My guess is that it's related to a slow DHCP server though.
    Thursday, May 10, 2018 7:25 PM
  • I just had this issue with a USB3 hub and a Panasonic ToughPad.

    I had a folder left over from a previous attempt to image.

    After removing the "MININT" folder, it boots properly.

    Only drivers I had in the WinPE selection were network card drivers, no mass storage, no display.

    Friday, July 20, 2018 8:07 PM
  • I've had different behavior from USB media, whether boot media or deployment-share-on-a-stick, depending on whether I'm using USB 2.0 or 3.0.  I've heard that this issue is fixed, but I'm not wholly convinced.

    I'd try adapting down to 2.0 with an extension cable or something, and see what happens.

    Monday, July 23, 2018 3:20 PM