locked
Skip missing features while exporting subsite? RRS feed

  • Question

  • Hi,

    Is there any way to walk around the error of missing feature when exporting site like this .. "Feature '75a0fea7-040e-4abb-b94b-32f1e7572840' for list template '106' is not in
    stalled in this farm.  The operation could not be completed."

    I have no intention to install the features in the farm because there are many missing features and i don't want to use them, i tried to uninstall the feature from the site using the command "uninstallfeature".. i got the message "operation successfully completed" but still i get the error.

    Thanks


    Monday, May 16, 2011 4:04 PM

Answers

  • Abdullah,

    First, you need to determine what feature is it? Is it Out of the box feature or custom feature? Either ways, when you are exporting and importing the site, you would need all the features that are available on the source farm in the destination farm.

    You can get rid of the features by uninstalling the feature using stsadm -o uninstallfeature in the source farm. This would remove the feature completely uninstall the feature from the farm. The other way is to copy the unavailable feature in the destination farm from source farm 12\features\[Featurename] and installing the feature.

    The error indicates that the features were not correctly installed. You will need to reinstall the features. Also, did you install SP2?


    V
    • Marked as answer by Abdullah_b Wednesday, May 18, 2011 9:19 AM
    Monday, May 16, 2011 5:36 PM