none
Protection agent cannot be installed on machine where dpm is installed RRS feed

  • Question

  • Hi,

    Using DPM 2016 with the update rollup installed on both servers. I'm trying to install the agent on the primary DPM server so I can replicate the backups to the secondary DPM server. I can't install the agent.

    It just gives me the following error "Protection agent cannot be installed on machine where dpm is installed"

    However, it is my understanding that installing an agent in this way should work.

    Source Here

    Please note, I am aware that historically this has been an issue in DPM 2012 when people try to install the incorrect version of the client, however I am running DPM 2016.

    I've tried the agent files from the C:\Program Files\Microsoft System Center 2016\DPM\DPM\ProtectionAgents\RA\5.0.158.0\amd64 directory and directly from the version extracted from the ISO.

    Both have the same issues.


    • Edited by Andrew Busby Friday, December 2, 2016 12:03 PM url
    Friday, December 2, 2016 12:02 PM

All replies

  • When you install DPM Server, agent gets installed with it. All you need to do is attach the primary DPM on Secondary DPM (Management/Agents/Install and then select attach).

    Tornado

    • Proposed as answer by BOETORNADO Tuesday, September 18, 2018 11:43 AM
    Friday, December 2, 2016 1:56 PM
  • Thanks for reply,

    I tried to attach it, but it fails. That's why I tried to install it.

    Data Protection Manager Error ID: 270

    The agent operation failed on ATS-P-DPM2016.local.domain.co.uk because DPM could not communicate with the DPM protection agent. The computer may be protected by another DPM server, or the protection agent may have been uninstalled on the protected computer.
    If ATS-P-DPM2016.local.domain.co.uk is a workgroup server, the password for the DPM user account could have been changed or may have expired.

    I tried looking for  SetDpmServer.exe but its not present in the directory.

    Friday, December 2, 2016 2:14 PM
  • Try disable firewall on primary server then attach it and dont forget to enable firewall back.

    Tornado

    Friday, December 2, 2016 2:38 PM
  • Firewall is already turned off.

    Friday, December 2, 2016 2:55 PM
  • I solved this. The person who configured it had set the DPM service account to run as a user rather than as local machine.

    • Proposed as answer by BOETORNADO Tuesday, September 18, 2018 11:43 AM
    Monday, December 5, 2016 11:30 AM