locked
User Permissions in MOSS 2007 RRS feed

  • Question

  • Hello,

     

    I have a question regarding the User Permissions in MOSS 2007. In our company portal, there are different user groups created for each website that was created under the main home portal. The problem is, even though i have admin rights added to the owners group of the home portal, i am unable to edit some of the pages present under some projects. I added my self to the Farm Administrators also. Can you tell me what i am missing?

    And another issue, there are some users who have the access to edit the pages. But sometimes, they do not see the edit option when they try to edit the page in site settings. They have the contribute permissions. I asked them to clear the browsing history and cache and restart the browser and machine. Then they were able to see the edit page option.

    I know i am missing something, can you help me please.

     

    Thank You

    Venkat. 

    Tuesday, December 13, 2011 4:56 PM

Answers

  • You should provide yourself (or your administrators) with a full control web application user permission policy for the web application. You do this in Central Administration -> Application Management -> Policy for Web Application.

     

    Here are instructions for setting the user permission policies for SharePoint 2010, it is the same for MOSS 2007.




    • Edited by Jason Warren Tuesday, December 13, 2011 11:06 PM
    • Marked as answer by Pengyu Zhao Wednesday, December 21, 2011 6:37 AM
    Tuesday, December 13, 2011 10:57 PM
  • Assuming you want to see and edit everything, then add yourself to Site Collections Admins. (It's a seperate input from the groups.  Settings, Site Settings, Top Level Site, Site Collection Admins.

    From there, it's anybody's guess how you have your permissions arranged. If inheritance is broken on one site(which you said project, which I assume is a site.), then the permissions are whatever is specified for that site.  Same goes for every list & library within the site.

    Permissions can be a nightmare, due to this, so better to get a handle on it now then when you get another 500 sites in the collection.


    Steve Clark, MCTS | Twin-Soft.com
    • Marked as answer by Pengyu Zhao Wednesday, December 21, 2011 6:37 AM
    • Unmarked as answer by venkat thrinath Wednesday, January 4, 2012 1:57 PM
    • Marked as answer by venkat thrinath Wednesday, January 4, 2012 1:57 PM
    Tuesday, December 13, 2011 9:50 PM

All replies

  • Assuming you want to see and edit everything, then add yourself to Site Collections Admins. (It's a seperate input from the groups.  Settings, Site Settings, Top Level Site, Site Collection Admins.

    From there, it's anybody's guess how you have your permissions arranged. If inheritance is broken on one site(which you said project, which I assume is a site.), then the permissions are whatever is specified for that site.  Same goes for every list & library within the site.

    Permissions can be a nightmare, due to this, so better to get a handle on it now then when you get another 500 sites in the collection.


    Steve Clark, MCTS | Twin-Soft.com
    • Marked as answer by Pengyu Zhao Wednesday, December 21, 2011 6:37 AM
    • Unmarked as answer by venkat thrinath Wednesday, January 4, 2012 1:57 PM
    • Marked as answer by venkat thrinath Wednesday, January 4, 2012 1:57 PM
    Tuesday, December 13, 2011 9:50 PM
  • You should provide yourself (or your administrators) with a full control web application user permission policy for the web application. You do this in Central Administration -> Application Management -> Policy for Web Application.

     

    Here are instructions for setting the user permission policies for SharePoint 2010, it is the same for MOSS 2007.




    • Edited by Jason Warren Tuesday, December 13, 2011 11:06 PM
    • Marked as answer by Pengyu Zhao Wednesday, December 21, 2011 6:37 AM
    Tuesday, December 13, 2011 10:57 PM