locked
Task Manager not respecting auto-raise with focus follows mouse RRS feed

  • Question

  • Hello,

    I just upgraded my laptop from Windows XP to Windows 7, and have enabled the same X-mouse style functionality that I had been using in XP - almost. Things are generally working well, except that Task Manager is not respecting my auot-raise setting. I would appreciate your assistance in configuring the Task Manager to behave like the rest of the applications on my Windows 7 desktop.

    What I would like to do is:

    • ENABLE focus follows mouse
    • DISABLE auto-raise (default)

    I've configured this environment by editing the HKEY_CURRENT_USER\Control Panel\Desktop\UserPreferenceMask registry key. Specifically, I:

    • ADDED 0x01 to the first byte, to enable 'focus follows mouse'
    • DID NOT ADD 0x40 to the first byte, to preserve the default auto-raise setting of disabled

    The desktop mostly behaves as I exect, with windows becoming active as I move my mouse over them, but retaining their existing ordering (i.e. not auto-raising). So far, so good.

    The Task Manager application, however, always auto-raises. For the last decade or so, I've kept the Task Manager open on my desktop all of the time; I use Task Manager more than any other application. Task Manager usually lurks behind the other windows that I'm using, peeking out around the edges so I can click it quickly when I want to see what my computer is doing. The problem now, however, is that if I even graze the Task Manager window with my mouse while sliding it across the screen, the Task Manager jumps to the front.

    I've adjusted the ActiveWndTrkTimeout key in an attempt to mitigate the issue. If I increase it to a large enough value to avoid the Task Manager problem, though, 'focus follows mouse' becomes so sluggish as to be unusable. What I really would like is for Task Manager just to behave like every other window.

    Therefore, my question is:

    Q: How do I prevent Task Manager from auto-raising when 'focus follows mouse' is enabled (and auto-raise is alreay disabled)?

    Thank you, in advance, for your help.

    Monday, July 19, 2010 7:11 PM

All replies

  • Hi,

     

    Please confirm if the “Always on Top” option in Task Manager->Options is checked. If so, please uncheck it to test the issue.

     

    Also, please check if it can be fixed by uninstalling X-Mouse temporarily? If so, you may consider to update X-Mouse or uninstall it.

     

    In addition, please modify the scripts in the following link to test:

     

    X-Mouse setting tool on Windows 7/Vista

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Hope it helps.

     

    Regards,

     

    Sabrina

    Thursday, July 22, 2010 9:34 AM
  • Please confirm if the “Always on Top” option in Task Manager->Options is checked.

    The 'Options' | 'Always On Top' feature is un-checked.

    Also, please check if it can be fixed by uninstalling X-Mouse temporarily?


    When I disable the 'focus follows mouse' feature (i.e. remove 0x01 from the first byte of UserPreferenceMask) the problem goes away, as expected.

    Regarding the C# class you reference, is there somthing specific that you would like me to test? I only write a little .NET on the side, but if I'm reading the code correctly, the only thing it does is change the UserPreferenceMask and ActiveWndTrkTimeout registry keys. This is the same thing that I've been doing manually with regedit.exe. If I'm overlooking something special in the program, please let me know.

    Thanks for taking the time to respond.

    Thursday, July 22, 2010 5:30 PM
  • I just finished setting up SQL Server 2008 - and Management Studio is auto-raising like Task Manager.

     

    Q: Is anyone else experiencing the same behavior with either Task Manager or SQL Server Management Studio?

     

    Even if there are no solutions, I'd be curious as to whether this auto-raise issue is specific to my computers, or whether it's a generic Windows 7 problem.

    Note that I'm seeing the problem on both of my Windows 7 computers - one x64 Ultimate, and one x64 Professional. I'm assuming that this means the problem applies to all Windows 7 installations. But, it might also be the case that I happened to tweak the same setting on both of my own machines and precipitated the same behavior.

    I know the X-mouse community isn't that big but, still, there are enough of us where I figure that others would be noticing this issue if it were widespread. Just curious what other X-mouse users are experiencing.

    Saturday, July 24, 2010 3:59 AM
  • Q: Is anyone else experiencing the same behavior with either Task Manager or SQL Server Management Studio?


    Yes, I can confirm the same behavior with Task Manager on a fresh install of Windows 7. As far as I know, this problem doesn't occur in Windows Vista or Windows XP.


    Microsoft MVP Windows Desktop Experience
    Saturday, July 24, 2010 11:11 AM
    Answerer
  • I've been looking for a way to do this for YEARS. Now all I need is middle-mouse cut/paste and Win 7 will have the same level of mouse functionality as Unix 15 years ago.

    If the Windows team ever gets around to fixing Windows not raising, taskbar buttons not working etc. we could almost have an OS where the end user gets to decide what he is looking at and when.

    ...but I'm sure Windows 8 will be out by then and it will suck even harder.

    ...Oh yeah, and this bug does exist.


    If you buy three cars and the same wheel falls off all three, do you contact the person who sold you the cars or the person who made them?
    Tuesday, July 27, 2010 4:58 AM
  • I'm getting the exact same problem: the task manager auto-raises :(
    Saturday, October 30, 2010 3:25 AM
  • OneNote 2010 also has this problem, and I would dearly love to find a solution. 

     

    Thursday, November 4, 2010 7:09 AM