none
Queue stuck on Prepare Project Web App Permission Synchronization RRS feed

  • Question

  • I have a customer with a PS2013 deployment (two app servers and 1 db server) updated to 15.0.4815.1000

    This PWA instance (with Project Server permission mode) has been succesfully being used for training and we are almost ready to go live on production.

    I added 331 resources to the Resource Center from Project Pro. After that I saved a new project from an MPP file. All went well there. When I clicked "Publish", nothing happened. I checked PWA queue and founded there that the job with position 1 is "Prepare Project Web App Permission Syncrhonization".

    This job shows as 100% but in the state it still says "Processing" and has no end timestamp. No errors. Have several more jobs stuck on the queue but it seems to be frozen.

    I restarted the Project Server Queue service but also ended in the same situation.

    Since the job has not failed, I have no error to diagnose but the queue status has not changed from the last 18-20 hours or so. CPU and memory on the server seem to be OK since they are below 40%.

    Any ideas on this are most welcome and wanted.


    Rene Alvarez

    Thursday, March 16, 2017 6:22 PM

Answers

  • Turned out to be a database problem. Logs were full and thus the queue did not process anything.

    After asking DBA to maintain the DB and restarting the Project Server Queue Service, all jobs processed successfully.


    Rene Alvarez

    • Marked as answer by René Alvarez Thursday, March 16, 2017 10:07 PM
    Thursday, March 16, 2017 10:07 PM