A failure occurred while validating the MAP Toolkit configuration database? RRS feed

  • General discussion

  • I'm trying to share a Windows 7 workstation which has the MAP toolkit v8 installed with another user.

    I've successfully installed and used the MAP toolkit as "DOMAIN\userA".

    However, when user "DOMAIN\userB" logs onto the workstation and launches the tool, elevated, they get this error:

    I'm not expecting "userB" to have access to the localDB databases created by "userA", since they will make their own databases to use.

    Monday, March 4, 2013 4:41 AM

All replies

  • Following the advice in the error message I asked "userB" to run the installer and perform the repair as suggested.

    This appeared to work and allowed both userA and userB to launch the application.

    I'm expecting the same problem to re-occur when userC wants to use the application, I guess each different user will be required to perform a repair install before they can launch the application.

    Monday, March 4, 2013 7:51 AM
  • Your suspicion would be correct.  By default, the MAP Toolkit will install SQL Server 2012 Express LocalDB during setup. As LocalDB is specific to the user account that installed it, You will only be able to run it from the initial account that did the installation.  The repair process is actually placing LocalDB on the second user accuont and creating a new instance for MAP to reference. 

    You may use an existing (or new) installation of SQL Server 2008, SQL Server 2008 R2, or SQL Server 2012 if you create an instance named "MAPS" before running the MAP Toolkit installer. The MAP Toolkit requires the collation order of the database engine to be set to "SQL_Latin1_General_CP1_CI_AS".   Doing this will allow multiple user accounts to use MAP and share databases.

    Tuesday, March 5, 2013 1:44 AM
  • Thanks Michael, I used your advice and solved the problem as follows:

    1. exported all the databases we wanted to keep. (this creates SQL backup .bak files)

    2. uninstalled the MAP tool from the PC.

    3. uninstalled SQL 2012 localDB.

    4. installed SQL 2012 with SP1 express with tools, then CU2, being careful to name the instance "MAPS" as per your tip.

    5. installed the MAP tool, which curiously didn't ask which database we wanted to use and used the MAPS instance from the previous step.

    6. launched MAP and imported the databases we wanted to use. (this performed a SQL restore of the .bak files).

    7. used SQL studio full edition (feature of SP1 express) and tweaked each database by setting auto-close to false, which makes the MAP tool start and operate faster.

    Tuesday, March 5, 2013 8:22 AM
  • Open an old thread...

    Did you (User B) ever tried to run MAPT as administrator >> "Right click > Run as Administrator"?

    • Edited by c0zzman Tuesday, June 24, 2014 9:07 AM
    Tuesday, June 24, 2014 9:06 AM
  • I have the same issue with MAP 9.1.

    Map Toolkit version 9.1

    UserA- Domain user and a Local administrator.

    User B- Domain user and a Local administrator.


    User A configured the Map with SQL Server 2012 Standard DB with the collation order of the database engine set to "SQL_Latin1_General_CP1_CI_AS".  

    Each DB setting is auto-close - False. Still User B/C/D get the same error. appreciate pointers

    Thursday, August 21, 2014 6:44 PM
  • Replying to an old thread, but might be useful for someone..

    Had this issue when changing domain on the Windows client where Map Toolkit was installed. The domain was changed so I could scan the Active Directory from a different domain in the end customer's environment.

    I solved it by:

    1. Logged on the Windows client with an administrator account from the new domain

    2. Pressed Shift+right click and then selected "Run as different user" on MapToolkit.exe

    3. Used an administrator account from the previous domain in the "Run as different user" logon window (the domain where Map Toolkit was initially installed)

    4. Started a Map Toolkit scan towards the new domain with an administrator account from the new domain

    No repair needed

    Thursday, March 19, 2015 12:44 PM
  • just run a repair on the tool from appwiz.cpl. this fixed it for me.
    Thursday, May 3, 2018 3:10 PM
  • This is because you installed MAPToolkit and created an initial database with a user and now you're trying to run the tool with another user. So this alert is that you are not having access permission with this user to load the database and start the tool. Make sure that you are using the same user profile on which MAPtoolkit was installed
    Thursday, September 20, 2018 2:55 PM