locked
Combining documents without changing individual headers on each RRS feed

  • Question

  • I have 3 separate word documents that I want to combine and send as one document but I need to keep the 2nd and 3rd pages HEADERS UNCHAGNED for EACH  document.  For example, if the first document is three pages long, the header will be displaced as Page 2 and Page 3.  The I do a BREAK, insert my second document which is 4 pages long, so I want the header on that document to be displayed at Page, 2, Page 3, Page 4.  BUT when I insert this second document Page 4 shows up as Page 7.  HELP!

    What am I missing?  What can I do to correct that problem?  Thanks.

    Friday, July 28, 2017 3:00 PM

All replies

  • You need to insert a 'Next Page' Section break at the end of the document you're inserting into - before doing the insertion - and unlink the new Section's headers & footers from the previous Section. You could automate that with a macro like:

    Sub Demo()
    Application.ScreenUpdating = False
    Dim HdFt As HeaderFooter
    With ActiveDocument
      .Range.Characters.Last.InsertBefore vbCr
      .Range.Characters.Last.InsertBreak wdSectionBreakNextPage
      With .Sections(.Sections.Count)
        For Each HdFt In .Headers
          HdFt.LinkToPrevious = False
        Next
        For Each HdFt In .Footers
          HdFt.LinkToPrevious = False
        Next
      End With
    End With
    Application.ScreenUpdating = True
    End Sub

    For PC macro installation & usage instructions, see: http://www.gmayor.com/installing_macro.htm
    For Mac macro installation & usage instructions, see: http://wordmvp.com/Mac/InstallMacro.html


    Cheers
    Paul Edstein
    [MS MVP - Word]

    • Proposed as answer by Steve Fan Monday, July 31, 2017 8:37 AM
    Sunday, July 30, 2017 10:14 PM
  • I actually did that, I just neglected to put in that I click BREAK and then NEXT PAGE, then INSERT text from new document, but it still didn't work.  THANK YOU SO MUCH for the MACRO though, that will make it easier.  Any other suggestions?  The headers are still numbered incorrectly.  I'm frustrated.   

    vjyoung52

    Tuesday, August 1, 2017 4:35 PM
  • You can set page number restart options in the Page Number Format dialog box, for each section. In ribbon versions of Word, click Insert | Page Number | Format Page Numbers. Click in the next section and repeat the procedure. See also http://wordfaqs.ssbarnhill.com/FrontMatterRibbon.htm.


    Stefan Blom, Microsoft Word MVP

    • Proposed as answer by Charles Kenyon Wednesday, August 2, 2017 11:58 AM
    Tuesday, August 1, 2017 7:56 PM
  • Note that when you restart page numbering in a section and then create a new section following that, the new section, by default, will also restart page numbering.

    Charles Kenyon Madison, WI

    Wednesday, August 2, 2017 12:00 PM