none
Error: Access Denied to one user RRS feed

  • Question

  • We have working Project Server 2010 and SharePoint 2010 with many active users and projects. But...

    One user receive error Access Denied on <serverurl>/PWA site and subsites (but user can access root site <server url> with appropriate permissions).

    On <serverurl>/PWA user exists as resource with access in PWA and in security group Administrators (in site permissions i can check that user have level granted from this admin group).

    I tried delete user from pwa and sharepoint "Remove-SPUser "domain\username" –web <serverurl>/pwa" than re-create user in resource pool, but this attempt gave no results - error access denied. 

    I tried delete user from pwa and sharepoint "Remove-SPUser "domain\username" –web <serverurl>/pwa" than on pwa sub-site <serverurl>/pwa/test and give to this user admin permissions, but user receive - access denied.

    When i change in project resource pool user account to "domain\testuser" - i can access to project pwa site. Also i tried stsadm.exe - migrateuser (but i not fully understand what that means)

    In ULS only one message ....PWA/_layouts/AccessDenied.aspx?Source=... , in event viewer no error messages.

    Big thanks for suggestions 


    Wednesday, September 5, 2012 6:38 AM

All replies

  • Try , PWA>>Manage Users and click the affected user for editing.

    Without making any chnages , click on save. This will resync the user with site collection


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Wednesday, September 5, 2012 3:26 PM
    Moderator
  • Thank you.

    I re-save user and after user sync job finished in queue - i try to login with this problem user, but again receive error access denied.

    In our test environment this AD user exists as resource and can login without errors.

    Wednesday, September 5, 2012 3:45 PM
  • Try logging to

    http://servername/pwa/_layouts/pwa/home/personalsettings.aspx


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Wednesday, September 5, 2012 3:48 PM
    Moderator
  • I can open this link with my admin account, but when i tried login as another user - type login and pass of problem user -  receive error access denied.

    i think that problem user is banned on our production server :-(

    Wednesday, September 5, 2012 3:57 PM
  • Looks like account is inactive in Project Server database

    Execute following SELECT query on prodcution Project Server published database

    select res_type from msp_resources where wres_account like 'Enter your PWA admin account here'

    Account is inactive If RES_Type is 102 and 2 indicates active user.


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Wednesday, September 5, 2012 4:07 PM
    Moderator
  • Problem account and my account has res_type =2, we have 166 inactive users as i can see with this sql query.

    As i notice in my first message i tried many times to delete user from project and after delete - checked in published db in msp_resources there is no problem user(i searched for ad user domain\username).

    Wednesday, September 5, 2012 5:11 PM
  • Since you have already created this user multiple times in PWA, may be issue is with AD account.

    Do you have any other test account in PWA, where you can use this problem user as windws account and try to repro this issue.

    Did you check whether account is disable or locked out in AD?


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Wednesday, September 5, 2012 5:59 PM
    Moderator
  • May issue with AD account sounds like - "domain\problem user" banned on our production project server ? Because on our test project server this user "domain\problem user" can successfully login.

    On production server we have testusers and i tried to rotate AD accounts in resource properties:

    test1 (domain\test1)

    problemuser (domain\problemuser)

    As result - problemuser(domain\test1) can login to project server, test1(domain\problemuser) receive "error access denied".

    :-(

    Thursday, September 6, 2012 6:34 AM
  • Remove it from the resources in Project server completely and add him back as resource onto the server

    Once when I was dealing with project server, I forget about Resource manager and concentrated on SharePoint .

    Tuesday, November 20, 2012 8:22 PM