locked
Vista at boot and before loading Task Bar or Start Menu displays error: rundll32.exe Windows cannot access specified device path or file. You may not have the appropriate permissions to access this item. RRS feed

  • Question

  • Windows Vista, at boot and before I see the Start Menu displays the following error message:

    rundll32.exe

    Windows cannot access specified device path or file. You may not have the appropriate permissions to access this item.


    This also happens in Vista Safe Mode, where after clicking on OK, only the black Safe Mode screen is there, no Start Menu or Task Bar. I can CTRL+ALT+DEL to get the Processes displayed etc., but cannot do anything else. This happens when I use any of my many drive images going back to 2009.


    Unusual circumstances: My Vista installation itself is on a V: Drive, not C: Drive. I managed to install it that way originally by doing a full install from another OS to a separate partition and not doing the install from a Vista DVD. The original Hard Drive is gone and this is my first attempt to boot into a new hard drive after imaging it with the old Vista drive image.


    Once again, I do not get the task bar or the start menu to allow me to enter into registry. Virus is unlikely as I have multiple drive images which worked until original hard drive died.

     

    EDIT:  CTRL + ALT +DEL > Start Task Manager > Application TAB > New Task... > explorer.exe > OK


    I now get the Start Menu + Task Bar. The drive's letter is G instead of V and this is the problem.

    The solution would be to change the drive letter, but how?
    Right Clicking on Computer > Manage does not populate the screen.


    I have access to the registry and also to the Device Manager now. How can the OS drive letter be changed to V?

     

    EDIT 2: [RESOLVED]

     

    Log on as Administrator > Start Menu > regedit.exe > HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices >

    If you want to change drive letter G: to V:

    1. First rename \DosDevices\V: to \DosDevices\Z: (to free it up)
    2. Now you can rename \DosDevices\G: to \DosDevices\V:

    Drive letter G will become drive letter V upon reboot.


    Thank you h055 of overclockers.com/forums for the solution. More details on source of solution here:

    http://www.overclockers.com/forums/showthread.php?p=6787750

    Wednesday, March 2, 2011 4:14 AM

Answers

  • EDIT 2: [RESOLVED]

     

    Log on as Administrator > Start Menu > regedit.exe > HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices >

    If you want to change drive letter G: to V:

    1. First rename \DosDevices\V: to \DosDevices\Z: (to free it up)
    2. Now you can rename \DosDevices\G: to \DosDevices\V:

    Drive letter G will become drive letter V upon reboot.


    Thank you h055 of overclockers.com/forums for the solution. More details on source of solution here:

    http://www.overclockers.com/forums/showthread.php?p=6787750

    Thank you for your useful information. Your time and effort is appreciated.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, March 7, 2011 7:26 AM
    Moderator