none
Orphaned Projects show up in Project Center (MSP 2013 Server on prem) RRS feed

All replies

  • Hi John,

    From the Project Centre you are initially looking at the published database.  When you review Delete Enterprise Objects, you can select the database to delete projects from.  Are they deleted from both drafts and published...?


    Ben Howard [MVP] | web | blog | book

    Tuesday, November 11, 2014 12:22 PM
  • Hi John 

    no the system do not require an overnight process to remove the projects. is this an on premise farm, which version? and when you performed the delete  can remember which selection you have had in the radio button selection that give you the option to delete from which database 

    regards 

    Malek


    Malek AlShayeb

    Tuesday, November 11, 2014 12:25 PM
  • I see, so the solution I tried did not show up any orphaned projects in published for some reason.

    The following sql statement is giving me a list including the projects in question.

    SELECT        pub.MSP_PROJECTS.PROJ_NAME, pub.MSP_PROJECTS.PROJ_UID, MSP_PROJECTS_1.PROJ_NAME AS [Name From Draft],
                             dbo.MSP_EpmProject.ProjectName AS [Name From Reporting]
    FROM            pub.MSP_PROJECTS LEFT OUTER JOIN
                             dbo.MSP_EpmProject ON pub.MSP_PROJECTS.PROJ_UID = dbo.MSP_EpmProject.ProjectUID LEFT OUTER JOIN
                             draft.MSP_PROJECTS AS MSP_PROJECTS_1 ON pub.MSP_PROJECTS.PROJ_UID = MSP_PROJECTS_1.PROJ_UID
    WHERE        (MSP_PROJECTS_1.PROJ_NAME IS NULL) AND (dbo.MSP_EpmProject.ProjectName IS NULL)

    Would I be correct in saying that

    EXEC MSP_Epm_DeleteResourcePlan '00d48b96-25f0-e211-9407-00155d10040a'

    EXEC MSP_Epm_DeleteProject 'Specify ‘00d48b96-25f0-e211-9407-00155d10040a'

    with the appropriuate UIDs would remove those projects from Published?

    Many thanks

    John

    Tuesday, November 11, 2014 12:58 PM
  • Hi Malek

    It is on premises, with SP1 and the September cu installed.

    Unfortunately I did not delete said projects, so I'm not sure which options were selected.  I shall keep an eye on what's going on though, to attempt to prevent it re-occurring.  I may even further restrict access to the delete options.

    John.

    Tuesday, November 11, 2014 1:00 PM
  • I gave that a go and sadly it did not resolve the issue, the orphaned entry is still in the published tables.

    Any thoughts?

    John

    Tuesday, November 11, 2014 1:04 PM
  • Hi John 

    to begin with please do not delete any rows from the database directly, is there any jobs stuck in the queue ? if yes what are they if no  try and perform  a reporting database rebuild that should get rid of any orphan projects

    regards

    Malek 


    Malek AlShayeb

    Tuesday, November 11, 2014 1:51 PM
  • Hi Malek

    Sadly no queue jobs are stuck in the queue, so nothing there.  The orphaned records are in the published database, so a rebuild of reporting doesn't seem like it would work.

    Thankfully the reporting records don't exist, so at least we won't get them included in any enterprise reports we run.  The only real issues is that they show up in Project Center.

    John

    Wednesday, November 12, 2014 8:51 AM
  • Hi,

    Is your project displayed when you try to delete the enterprise objects and select Delete published projects only? If so, have you tried to delete it from there?

    Also, if you are using the archive you can try to restore an archived version, publish the project and then re-try deleting it

    Hope this helps

    Paul

    Wednesday, November 12, 2014 9:57 AM
  • if none of the suggestions work , try to save and publish an empty project with the same exact name that should overweight the one stuck in the publish DB and then you can try and delete them again 

    regards 

    Malek


    Malek AlShayeb

    Wednesday, November 12, 2014 10:20 AM
  • Hi Malek

    Now that sounds like a plan, I'll let you know how I get on.

    John

    Wednesday, November 12, 2014 1:48 PM
  • Hi Malek

    Sadly no joy there, the project saves ok but errors on publish.  I attempted the delete anyway and it removed the draft entry but not the published.

    John

    Wednesday, November 12, 2014 1:55 PM
  • what type of errors ? 


    Malek AlShayeb

    Wednesday, November 12, 2014 2:01 PM
  • Hi John,

    I would expect errors as you already have the other project with the same name (but never had similar situation)

    Have you tried to restore an archived version of the project? Once restored, publish it and finally delete the project (this will work only if you have an archived version of the project)

    Paul

    Wednesday, November 12, 2014 2:17 PM
  • what type of errors ? 


    Malek AlShayeb

    The publish failed and blocked the queue.  I read through the error message but sadly it didn't have anything concrete to go on in there.  I cancelled it so unfortunately lost the message.

    Thursday, November 13, 2014 9:14 AM
  • Hi John,

    I would expect errors as you already have the other project with the same name (but never had similar situation)

    Have you tried to restore an archived version of the project? Once restored, publish it and finally delete the project (this will work only if you have an archived version of the project)

    Paul

    Sadly no copies in the archive.  We had a provisioning problem that prevented the overnight processes for a short while, so no archives were created.  I believe they were deleted before we resolved the error.

    John

    Thursday, November 13, 2014 9:15 AM
  • Hi John 

    have tried to delte other projects ? did they delete ok ? if not can you try to delete one and keep an eye on the ULS log and see how that goes 

    regards 


    Malek AlShayeb

    Thursday, November 13, 2014 9:51 AM
  • Hi John 

    have tried to delte other projects ? did they delete ok ? if not can you try to delete one and keep an eye on the ULS log and see how that goes 

    regards 


    Malek AlShayeb

    Hi Malek

    Other projects delete normally, there just seems to have been an issue with these few.  4 of them were deleted at the same time, so I suspect there was an issue at the time which we no longer have.

    John.

    Thursday, November 13, 2014 10:24 AM