locked
AppV 5.0 SP2 HF4 UnExpected Behavior RRS feed

  • Question

  • Has anyone seen an unexpected behavior after installing the HF4 install on a client or RDS server? In testing the H4 install. The install works great on my Sequencer machine. But same issue with RDS in Windows 2008 R2 and Windows 7 SP1 clients, it looks like it installs correctly. using the msp file, but when you try to load a pub app, the application fails with error (both apps created in SP2 and or HF4 - Failed to publish the package....

    Upon looking deeper, I have found that the M$ App-V Client service is stopped and cannot be restarted. (VClient.exe) Fails with a general error. Looking at Component Services, Something is failing to start. Does anyone have any thoughts on it?

    Tuesday, June 3, 2014 3:11 PM

Answers

All replies

  • Hello,

    Have you tried to execute the .exe-file, instead of using the MSP-file when installing HF4?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, June 3, 2014 3:35 PM
  • @Znackattack that's correct I tried the exe for the install first. Would not install, as it advised I already had another version installed. He to get around that with the msp route.
    Tuesday, June 3, 2014 3:58 PM
  • Hello,

    Did you restart the machine after applying the patch?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, June 3, 2014 4:40 PM
  • @Znackattack  Yes the machine was restarted after the install, during every testing instance. Have executed this test like twennty times now, using different methods. The install actually requires the power/reboot cycle of the client machine.
    Tuesday, June 3, 2014 6:57 PM
  • Hello,

    Did you configure anything on the client?

    The only issue I know about is this;

    http://trentent.blogspot.se/2014/05/appv-50-sp2-hotfix-4-hf4.html

    Otherwise I would Review what you saw in the event-log and determine what it means in your specific instance.


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, June 3, 2014 7:16 PM
  • Delete C:\ProgramData\Microsoft\AppV and see if the client service will start.
    Tuesday, June 3, 2014 10:07 PM
    Moderator
  • @CodyLambert - Yes I have also tested that... and no go, service does not start up. Thanks for responding!!
    Tuesday, June 3, 2014 10:11 PM
  • You need to install MS Visual C++ Redistributable 2013.. It's a new prerequisite with HF4. http://www.microsoft.com/en-us/download/details.aspx?id=40784
    • Edited by WGray_TSCG Wednesday, June 4, 2014 12:31 AM
    • Proposed as answer by znack Wednesday, June 4, 2014 8:33 PM
    • Unproposed as answer by Jorge Fernandez - US FL Wednesday, June 4, 2014 8:35 PM
    Tuesday, June 3, 2014 11:51 PM
  • That's correct we tested that as well and we saw the same issues even if C++ 2013 was installed. We are looking at our enironment and looking at some cleanup, and finding that AppV4.6 SP1 and AppV 4.6 RTM still existed on the machines. Currently looking at that....and running it down.

    Jorge Fernandez

    Wednesday, June 4, 2014 8:39 PM
  • So ran the 4.6 SP1 and RTM thing down. Found our issue...After multiple failings we had almost given up it was quite frustrating because the install seemed to work but after the install the AppV5 client was broke where you couldn’t install apps or run PoSh AppV commands.  We ruled out the media on a vanilla machine and were able to prove it was our environment.  We took a different approach and uninstalled the AppV5 client.  Then tried doing a fresh AppV5 Sp2 client install but it was failing.  It was complaining there was incompatibility with the previous AppV client,  This didn’t make sense, but sure enough AppV4.6 Sp1 was on the machine.  We went ahead and installed AppV4.6 Sp2 and then I was able to install AppV5 Sp2 and finally the AppV5 Sp2 HF install and have it all working now.

    Our mystery now is how do we have machines with AppV4.6 RTM or SP1 and Appv5 side by side when they don’t have AppV4.6 Sp2. We are running that down. Not sure how they can live side by side without issue. So the hunt gets deeper.


    Jorge Fernandez

    Friday, June 20, 2014 2:41 PM
  • Friday, June 20, 2014 6:16 PM
  • Correct that's the mystery that is/was a head scratcher....


    Jorge Fernandez

    Friday, June 20, 2014 7:37 PM
  • Enable Debug logging and look for dead catalogs:

    http://blogs.technet.com/b/virtualworld/archive/2014/04/12/app-v-5-0-etw-tracing-automation.aspx


    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    http://blogs.technet.com/gladiatormsft/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Wednesday, June 25, 2014 6:40 PM
  • Thanks!

    Jorge Fernandez

    Wednesday, June 25, 2014 6:59 PM
  • Hello,

    If it fails completely try to wipe the following things;

    Uninstall the client

    Remove Everything under;

    c:\programdata\appv

    c:\programdata\microsoft\appv

    HKLM\Software\Microsoft\AppV

    Reinstall the client and apply the hotfix


    Nicke Källén | The Knack| Twitter: @Znackattack

    Sunday, June 29, 2014 7:58 PM