none
Can't get Windows 10 Creators Update to ask for product key during OOBE. RRS feed

  • Question

  • Hi guys,

    I can't get my sysprepped image to ask the user for the product key during OOBE. I've installed the image from scratch, entering no key (skipped). Then I went to audit mode via sysprep, deleted accounts and install apps for our users (web browsers etc)

    I set up my answer file which runs after generalize and boots back into audit mode to run some scripts (which include installing the drivers for the computer it's deployed to) at the end of that it runs sysprep to go to OOBE from my script and shuts down. 

    Turning back on takes us in OOBE but it never asks for the product key, so the customer has to enter it from the settings menu later on. In my last test I tried adding all key related things I could find to my answer file but none of them have made a change, could anyone offer an answer? Here is my file below.

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <servicing></servicing>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <HideEULAPage>false</HideEULAPage>
                    <HideLocalAccountScreen>false</HideLocalAccountScreen>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>false</HideOnlineAccountScreens>
                    <HideWirelessSetupInOOBE>false</HideWirelessSetupInOOBE>
                </OOBE>
                <WindowsFeatures>
                    <ShowInternetExplorer>false</ShowInternetExplorer>
                </WindowsFeatures>
            </component>
        </settings>
        <settings pass="auditUser">
            <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <RunSynchronous>
                    <RunSynchronousCommand wcm:action="add">
                        <Order>1</Order>
                        <Description>Boot Camp Drivers</Description>
                        <Path>cmd /c C:\Windows\Panther\network.cmd</Path>
                        <WillReboot>Always</WillReboot>
                    </RunSynchronousCommand>
                    <RunSynchronousCommand wcm:action="add">
                        <Order>2</Order>
                        <Path>cmd /c C:\Windows\Panther\final2.cmd</Path>
                        <Description>Deecies Script</Description>
                    </RunSynchronousCommand>
                </RunSynchronous>
                <Reseal>
                    <ForceShutdownNow>true</ForceShutdownNow>
                </Reseal>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipAutoActivation>true</SkipAutoActivation>
            </component>
        </settings>
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <UserData>
                    <ProductKey>
                        <WillShowUI>Always</WillShowUI>
                    </ProductKey>
                </UserData>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:c:/users/daniel%20shepherd/desktop/install.wim#Windows 10 Pro" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    

    Wednesday, June 21, 2017 6:55 PM