locked
Virtual Network Adapter-issue RRS feed

  • Question

  • I urgently need some assistance, please.  I'm getting the following error on one of me Virtual Machines: "The IP address xxx.xxx.xxx.xxx you have entered for this network adapter is already assigned to another adapter ‘Microsoft Virtual Machine Bus Network Adapter’. ‘Microsoft Virtual Machine Bus Network Adapter’ is hidden from the Network Connections folder because it is not physically in the computer. If the same address is assigned to both adapters and they both become active, only one of them will use this address.  This may result in incorrect system configuration.
    Do you want to enter a different IP address for this adapter in the list of IP addresses in the Advanced dialog box?"
    I have deleted and reinstalled the network adapter, but it keeps on coming back with the same issue.
    Wednesday, May 22, 2013 9:06 AM

All replies

  • Fairly common, you just need to delete the old hidden adapter.

    See: http://support.microsoft.com/kb/269155

    Thursday, May 23, 2013 6:11 AM
  • Hi Steve, I have done this and as soon as I reboot the server, the duplicate network card is back with the same issue.

    How do I fix this issue permanently?

    Any idea what might have caused this in the first place?  This server has been running for more than two years without this issue.

    This is a Server 2008 R2 Hyper-V environment.
    • Edited by EttienneD Thursday, May 23, 2013 6:49 AM
    Thursday, May 23, 2013 6:48 AM
  • Are you assigning an IP address to the virtual network on the host?  If so, why?  You don't need to have an IP there, just on the vNics in the VMs themselves.
    Thursday, May 23, 2013 8:08 AM