none
How to turn off Compatibility Mode on Project 2010 RRS feed

  • Question

  • I am having trouble turning off Compatibility Mode on Project 2010 in our organization - Project is installed as part of Office Professional Plus 2010.

    When I open Microsoft Project it displays [Compatibility Mode] in the title bar.

    When I choose Save As, the type of file is "Microsoft Project 2007 (*mpp)". I can go ahead and change this each time to "Project (*.mpp)" but I would like this to be the default setting for all users.

    Under File, Options, Save - the "Save files in this format" is greyed out and set to "Microsoft Project 2007 (*mpp)".

    I have created a GPO under: User configuration - Policies - Administrative Templates - Classic Administrative Templates - Microsoft Project 2010 - Project Options - Save, and I have set "Save Microsoft Project files as" "Project (*.mpp)".

    My only other choices are "Template" or "Project 2000-2003"

    This GPO is applying correctly, however - Project continues to open in Compatibility Mode.

    In my GPO, should I be seeing a set of different option for "Save Microsoft Project files as"?

    Otherwise, am I missing something else in order to turn off Compatibility Mode for Project?

    Many thanks in advance!

    Wednesday, October 8, 2014 8:37 AM

Answers

  • An update on this issue, after reading the following page which describes someone else having the issue:

    http://workinghardinit.wordpress.com/2010/08/30/microsoft-project-2007-2010-default-format-when-saving-group-policy/

    I went ahead and checked the contents of the MS Project 2010 Group Policy Template (proj14.adm), and could see that indeed there is no mention of a Project 2010 default format - which would be denoted by a "14":

    POLICY !!L_PjFileType
                   KEYNAME "software\policies\microsoft\office\14.0\ms project\options\save"
                   EXPLAIN !!L_PjFileTypeExplain
                       PART !!L_pjfiletype30 DROPDOWNLIST
                           VALUENAME "DefaultSaveFormat"
                           ITEMLIST
                               NAME !!L_PjType0 VALUE "MSProject.MPP.12" DEFAULT
                               NAME !!L_PjType1 VALUE "MSProject.MPT.12"
                               NAME !!L_PjType2 VALUE "MSProject.MPP.9"
                           END ITEMLIST
                           NOSORT
                       END PART
               END POLICY

    As I mentioned in my previous post, I am able to allow the default format to be Project 2010 by setting my GPOs "Save Microsoft Project files as" state to "Disabled" - but it certainly does seem that the Project 2010 Group Policy Templates are not correct for this GPO setting.

    Does anyone have any info or solution to this?

    • Marked as answer by van_dihno Monday, November 3, 2014 1:25 AM
    Friday, October 17, 2014 8:28 AM

All replies

  • Hello,

    What do the other Office 2010 applications do, do these default to 2007 as well? Can you test on workstation that does not have any GPOs applied - Project 2010 should then use "Project (*mpp) format (or you will be able to set it back to the default.

    Also, are you using Project 2010 with Project Server 2010 or just Project 2010 standalone?

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS


    Wednesday, October 8, 2014 9:47 AM
    Moderator
  • Hi Paul,

    We are using Project 2010 standalone

    When I test this on a workstation with no GPOs applied, Project opens normally - ie not in Compatibility Mode.

    Our other Office Applications do not open in Compatibility Mode, and in the Options the "Save files in this format" setting is not greyed out.

    The single GPO contains all the Save settings for all Office applications; for Excel, PowerPoint and Word the setting is named "Default file format" rather than the "Save Microsoft Project files as" that Project does. I'm not sure if that is significant...

    The "Default file format" for Excel, PowerPoint and Word are:

    "Save Excel files as" "Excel Workbook (*.xlsx)"
    "Save PowerPoint files as" "PowerPoint Presentation (*.pptx)"
    "Save Word files as" "Word Document (*.docx)"

    Could it be something to do with not having the correct ADM/ADMX templates installed for Project?

    Many thanks,

    Van

    Thursday, October 9, 2014 7:19 AM
  • Hello,

    Can you test on a machine with just the Project GPO set to see if the Office one is conflicting somehow?

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Thursday, October 9, 2014 9:03 AM
    Moderator
  • Hi Paul,

    I have tested with a test GPO and these are the results:

    When "Save Microsoft Project files as" state is set to "Enabled": Opens in Compatibility Mode and under File, Options, Save - the "Save files in this format" is greyed out and set to "Microsoft Project 2007 (*mpp)".

    When "Save Microsoft Project files as" state is set to "Disabled": Project opens fine and under File, Options, Save - the "Save files in this format" is not greyed out and I can choose "Project", "Microsoft Project 2007", "Microsoft Project 2000-2003" and "Project Template".

    What I believe to be the problem is that "Save Microsoft Project files as" options that are available for me to choose in my GPO do not seem to be aware of Office 2010. The options available are:

    "Project (*.mpp)"
    "Template (*.mpt)"
    "Project 2000-2003 (*.mpp)"

    There is no specific mention of "Project 2007", it seems like the GPO recognises Project 2007 as the most recent when we are in fact using Office 2010.

    Could this be that my Group Policy Templates are for Office 2007 rather than Office 2010? That would be odd as the policy location itself is located under: User Configuration/Policies/Administrative Templates/Classic Administrative Templates/Microsoft Project 2010/Project Options/Save

    ...so as this specifically mentions Project 2010 I would assume that it is using the correct version.

    Another quick note: I needed to Add Template in GPME so that "Classic Administrative Templates" would be available, and the template I added was proj14.adm which I believe is the correct 2010 template.

    Many thanks,

    Van

    Thursday, October 16, 2014 7:00 AM
  • An update on this issue, after reading the following page which describes someone else having the issue:

    http://workinghardinit.wordpress.com/2010/08/30/microsoft-project-2007-2010-default-format-when-saving-group-policy/

    I went ahead and checked the contents of the MS Project 2010 Group Policy Template (proj14.adm), and could see that indeed there is no mention of a Project 2010 default format - which would be denoted by a "14":

    POLICY !!L_PjFileType
                   KEYNAME "software\policies\microsoft\office\14.0\ms project\options\save"
                   EXPLAIN !!L_PjFileTypeExplain
                       PART !!L_pjfiletype30 DROPDOWNLIST
                           VALUENAME "DefaultSaveFormat"
                           ITEMLIST
                               NAME !!L_PjType0 VALUE "MSProject.MPP.12" DEFAULT
                               NAME !!L_PjType1 VALUE "MSProject.MPT.12"
                               NAME !!L_PjType2 VALUE "MSProject.MPP.9"
                           END ITEMLIST
                           NOSORT
                       END PART
               END POLICY

    As I mentioned in my previous post, I am able to allow the default format to be Project 2010 by setting my GPOs "Save Microsoft Project files as" state to "Disabled" - but it certainly does seem that the Project 2010 Group Policy Templates are not correct for this GPO setting.

    Does anyone have any info or solution to this?

    • Marked as answer by van_dihno Monday, November 3, 2014 1:25 AM
    Friday, October 17, 2014 8:28 AM
  • All  you  have  to  do  is  when  you  save your  project go to  the "save  as" option. In  the  "save  as  type"    open  the  drop down and  select "project (mpp)" not 2007. This  will  now   open  your  2010 project   normally and  not in compatibility  mode. For  some  reason  2010  seems to  default  to   saving  in  2007, this  solves  the  problem.

    Regards Chris

    Wednesday, July 27, 2016 5:18 PM