none
Remote Desktop -- Windows 7 laptop accessing Windows 8 PC -- Code: 0x80004005

    Question

  • My employer just transitioned all office-based PCs to Windows 8. I'm running Widows 7 Home Premium 64 bit (SP1) on a laptop that hasn't been able to remotely access the upgraded work computer. The error message [when attempting to access 8.1 machines] is:

    "An authentication error has occurred (Code: 0x80004005)."

    It is still able to access XP-based computers. The laptop is on Remote Desktop Connection Shell Version 6.3.9600 (same control version). NLA is supported. Remote Desktop Protocol 8.1 supported. I'm able to remote into the work desktop from my two other home computers. 

    Our very large tech team is stumped by this too. Any help would be greatly appreciated.  

    Tuesday, April 22, 2014 1:58 PM

All replies

  • Hi,

    In your remote Windows 8 PC, type system in the search charm bar, then click "Remote Settings", Allow remote connection to this computer, select users, Since you are running Windows 7,you can check the Allow connections only from computers running Remote Desktop with Network Level Authentication (recommended) box.

    If you have any 3 rd  party security software installed, I suggest you temporarily disable them.

    Make sure your Windwos 7 PC is up-to-date.


    Yolanda Zhu
    TechNet Community Support

    Thursday, April 24, 2014 2:06 AM
    Moderator
  • All of the Windows 8 machine's settings are in good shape, per our IT department. The windows 7 laptop is up to date and is still able to remote in to XP computers just fine. 

    Any additional ideas, Yolanda [or anyone else]? 

    Tuesday, April 29, 2014 5:52 PM
  • I have found the almighty answer when no one else seems to have it. You can thank me with a beer.

    KKCO

    Please edit Default.rdp file as following steps to turn off the new
    features in Remote Desktop Connection 6.0 to revert to the features in
    Remote Desktop Connection 5.x.

        To do this, follow these steps:
        1. Click Start, click Run, type mstsc.exe, and then click OK.
        2. Click Options, and then click the General tab.
        3. Click Save As, and then type a file name in the File name box.
        4. Select the location where you want to save the remote desktop file,
        click Save, and then click Cancel.
        Note The saved file has the .rdp file name extension.
        5. Click Start, click Run, type notepad, and then click OK.
        6. On the File menu, click Open.
        7. In the Files of type list, click All Files.
        8. In the Look in list, locate and then click the file that you saved in
        step 4. Then, click Open.
        9. Locate the line that resembles the following:
        authentication level:i:n
        Note The n placeholder represents the current authentication level.
        10. Change the authentication level to 0 so that the line becomes the
        following:
        authentication level:i:0
        Note When you set the authentication level to 0, RDP 6.0 does not check for
        server authentication.
        11. Add the following line to the end of the file:
        enablecredsspsupport:i:0
        Note When this line is present, you do not have to provide credentials
        before you establish a remote desktop connection.
        12. On the File menu, click Save.

    Thursday, May 15, 2014 9:58 PM
  • I was having the same error message, and your 1 through 12 step process fixed it for me, thank you, I O you a Beer. spent hours reading unhelpful post. this one did it for me.
    Tuesday, July 22, 2014 11:00 PM
  • Cheers! This worked perfect for me also. Nice work... Robin


    Sir Stox

    Thursday, November 13, 2014 5:07 AM
  • Fantatic!

    Thank you.

    This resolved an unexplained authentication to a Terminal Server running 2008R2+ on only certain Windows 7 machines.

    Other Windows 7 machines can connect to the same machine without issue. It may be related to Registry entries.

    If I find a relation to the registry entries and getting the standard authentication entries to work, I will post a follow-up.

    Monday, November 16, 2015 10:00 PM