locked
Framekwork 3.5 installation issues RRS feed

  • Question

  • Hi All,

     I'm having a torid time trying to install Visual Studio 2008 on Vistal Ultimate. The issue is the installatin of Framework 3.5. Ive tried quite a few things but I end up with the same error: 
    "DepCheck indicates Optional Component 'Microsoft .Net Framework 3.0' is not installed."
    This is surprising considering that 3.0 is supposed to be part of Vista, and as such I can see it in the Windows\Microsoft.NET\Framework\3.0 directory. I've tried to install it separately using the dotNetFx35setup.exe package, same result. Looking at the generated log file - dd.dotnetfx35install.txt - is not very infrmative as far as I'm concerned. It containsconfusing entries, like:
    [12/27/08,17:47:38] InstallReturnValue: GFN_MID Optional Component 'Microsoft .Net Framework 3.0', 0x0
    [12/27/08,17:47:38] Optional Component 'Microsoft .Net Framework 3.0': Error code 0 for this component means "The operation completed successfully.
    which obviously doesn't mean what it says at least to DepCheck. I've cleaned the registry, made sure Vista SP1 is installed, reinstalled Windows installer 3.1, but nothing seems to help.
     If anyone has come across this kind of problem, I would really appreciate a hint or two how to overcome it. Honestly, my oppinion is that this kind of problem shuld have been sorted out by MS a while back. Neither Vista nor VS2008 are shining new anymore.

    Saturday, December 27, 2008 9:26 AM

Answers