locked
RHEL 63. with Linux Integration Services 3.4 in Server 2012 Hyper-V will not communicate with host or Server 2012 VM RRS feed

  • Question

  • I have a RHEL 6.3 VM with four legacy vNICs, attempting to communicate with the Server 2012 host and a Server 2012 VM. Linux Integration Services v3.4 are installed from the downloaded ISO image. In Server 2012 it will not communicate with either the host or another VM.

    Now, I built this RHEL 6.3 VM on Server 2008 R2, where it was able to communicate on two different subnets using the legacy vNICs. One of these was based on an external vSwitch, the other on an internal (but not private) vSwitch. After exporting this VM and importing it into Server 2012, where the same settable characteristics are present in the external and internal vSwitches, I see the above inability of the RHEL VM to communicate.

    Is my use of legacy vNICs, which enable communication on Sever 2008 R2, inappropriate for Server 2012? Should I expect to be able to use Server 2012 native vNICs, given the presence of Linux Integration Services v3.4? When I tried to accomplish that I got a kernel panic before I could install them, right after installing RHEL 6.3 in the VM. Anyone offer any suggests for trouble-shooting this? Any advice gratefully received.

    Cheers,

    jwl


    James Livingston


    Wednesday, March 20, 2013 6:52 AM

Answers

  • As it turns out, I was unaware that I had RHEL 6.1, rather than 6.3, in that VM. Once I'd learned that, and reinstalled the correct components from the Linux v3.4 IC ISO, I was able to delete the original legacy vNICs, delete the content of "/etc/udev/rules.d/70-persistent-net.rules", then reboot, after which the new eth* vNICs were recognized, corresponding to the Hyper-V native vNICs I had added to the VM. I could then set up the desired IP addresses, "cat /sys/class/net/eth0/operstate" gave the expected "up", and I could communicate with the Server 2012 host.

    I'm thankful for the amount of Linux information to be found on the Web, and apologize for not citing the specific pages that provided my solution.

    Cheers,

    jwl


    James Livingston

    Friday, March 22, 2013 1:16 AM