none
Host files does not work RRS feed

  • Question

  • Hello,

    I add one ip address maping to name. 180.150.xxx.xxx owa.xxx.xxx.xx

    dns cache flushed.

    when ping owa.xxx.xxx.xxx. I can get IP addresss correcly.

    when try log in by domain name. Internet explorer still forward old ip address.

    Please give guide what do we check for next?

    tks n brgds

    Liu Wei


    • Edited by lwsamcn Sunday, October 20, 2019 3:45 AM
    Sunday, October 20, 2019 1:26 AM

Answers

  • Hi ,

    >>when ping owa.xxx.xxx.xxx. I can get IP addresss correcly.

    If you get the correct IP address from ping, this means your host files is fine and the problem is elsewhere.

    Here is a thread talking about how to troubleshoot host file being ignored, you could have a look:

    hosts file ignored, how to troubleshoot?

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    >>when try log in by domain name. Internet explorer still forward old ip address.

    Please check if you are using a proxy server. If you have a proxy configured, it may pass the hosts file.

    In addition, clear IE cache to do a check.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    • Marked as answer by lwsamcn Monday, October 21, 2019 4:32 AM
    Monday, October 21, 2019 2:43 AM

All replies

  • Hi ,

    >>when ping owa.xxx.xxx.xxx. I can get IP addresss correcly.

    If you get the correct IP address from ping, this means your host files is fine and the problem is elsewhere.

    Here is a thread talking about how to troubleshoot host file being ignored, you could have a look:

    hosts file ignored, how to troubleshoot?

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    >>when try log in by domain name. Internet explorer still forward old ip address.

    Please check if you are using a proxy server. If you have a proxy configured, it may pass the hosts file.

    In addition, clear IE cache to do a check.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    • Marked as answer by lwsamcn Monday, October 21, 2019 4:32 AM
    Monday, October 21, 2019 2:43 AM
  • Hello, Cany,

    Agree what your advise! But we have problem connect to the destination server by  the domain name.

    we test on most of our  PCs and servers. all users can get new server by that domain name.

    But, strange  is that, Only a branch Company, all PCs and servers  of this branch could not get new server connection.

    My meaning browse that domain name, Old server response for those users.

    I never see this phenomena.

    That network is A Domain Network, Domain service as default. There are no customered service/

    Features on the Domain. servers are Virtual Machine built on Vmware Hypervisor. Firewall is Sophos.

    VM and Firewall also as default.

    So that I have no idea why those workstations are facing this problem.

    Brgds

    Liu Wei


    Monday, October 21, 2019 1:32 PM
  • Hi ,

    Thanks for your updating.

    Did you configure GPO to apply proxy settings to clients in domain?

    In order to narrow down the issue, I would suggest you perform the following steps on a problematical PC to do a test:

    1.Check if the IE is using the proxy server. 

    2.Clear IE cache.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Tuesday, October 22, 2019 2:04 AM
  • Hello, Candy,

    I got the root cause. The Sophos Firewall genertal setting (as default) filted out the host file mapping.

    I disabled the function. and get it solved.

    tks n brgds

    Liu Wei

    Saturday, October 26, 2019 8:26 AM
  • Hi ,

    I am glad to hear that your issue was successfully resolved.

    Highly appreciate your effort and time!

    Have a nice day!

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Monday, October 28, 2019 2:20 AM