locked
The ID 'DelegateControl1' is already used by another control. RRS feed

  • Question

  • Hello,

    I am having an issue with my portal. I was recently messing around with the SMPortalPage.master template in order to customize it and for some reason I started getting the following error:

    "The ID 'DelegateControl1' is already used by another control."

    If I delete the duplicate control it, the portal appears to work, however, the backend is still broken. Should the SMPortalPage.master be generic? If so, does someone have a copy of this master page?

    Is there anyway to reinstall the Service Manager web portal?


    • Edited by hhancock Monday, June 25, 2012 6:50 PM
    Monday, June 25, 2012 6:22 PM

Answers

All replies

  • Which version of SCSM 2010 are you running?

    Andreas Baumgarten | H&D International Group

    Monday, June 25, 2012 7:19 PM
  • We are running SCSM 2012 (7.5.1561.0)
    Monday, June 25, 2012 7:41 PM
  • If both SCSM 2012 components are installed on the same server (SharePoint Server) you should uninstall both components in one step. After the SCSM2012 components are uninstalled a new installation is possible. Never had any problem with this in our environments.

    Andreas Baumgarten | H&D International Group

    Monday, June 25, 2012 8:29 PM
  • Do you happen to have the original SMPortalPage.master page? I am wondering if somehow this was corruputed.
    Monday, June 25, 2012 9:08 PM
  • Hello,

    The Master page gallery of the Self Service Portal has version history enabled. Maybe you can restore an older version of the SMPortalPage.master? 


    - Dennis | Netherlands | Blog | Twitter

    Saturday, June 30, 2012 1:25 AM
  • Hello,

    We also run into this error. This was when we followed Anton his article on deploying the Microsoft.EnterpriseManagement.ServiceManager.Portal.SharePointSite.wsp solution file to another SharePoint environment.

    It looks like the masterpage provisioned in that solution contains some placeholders & controls with wrong id's.

    We compared this masterpage with the default v4.master. It seems to miss the PlaceHolderSearchArea, PlaceHolderTopNavBar, PlaceHolderHorizontalNav. It also misses the controls TopNavigationMenuV4, TopNavigationDelegate & TopSiteMap.

    After fixing this in the masterpage and uploading it we got rid of our error.

    Hope this helps.


    - Dennis | Netherlands | Blog | Twitter

    Friday, August 3, 2012 8:47 AM
  • Hi,

    Another possible reason fom my experience: SMPortalPage.master has been Checked Out by mistake in SPS user interface. I've used Check In back in SharePoint Designer to fix it.

    BR,

    Anatoliy

    Thursday, August 16, 2012 12:03 PM
  • Don't delete the "duplicate" control.  First ensure that your System Master Page is set to v4.master (http://sharepointservername:portnumber/smportal/_layouts/changesitemasterpage.aspx).  Next, go to your master pages (http://sharepointserver:portnumber/SMPortal/_catalogs/masterpage/Forms/AllItems.aspx), click the drop-down next to SMPortalPage.master, and choose 'Edit in Microsoft SharePoint Designer'.  Once SharePoint designer opens, choose 'Master Pages' under 'Site Objects'.  Right-click the SMPortalPage.master page and select 'Set as Default Master Page'.

    Refresh the portal and it should be fixed. 



    Friday, October 26, 2012 7:31 PM