none
Need to log on twice for hidde all icons on the desktop

    Question

  • Hello Everyone !
    First sorry for my bad English i am French !

    I applied a Gpo for hidde all icons on the user desktop
    (user configuration\Policies\Administrative templates\Desktop\Hide and disable all items on the desktop)

    The GPO apply correctly BUT ... the user need to log on twice for the icons desappeared from the desktop

    Any suggestion to avoid this double log on ??

    Thanks

    Wednesday, March 09, 2016 9:20 PM

Answers

  • Hi,

    It may be related to the Fast Logon Optimization, please try to disable it and check if the issue persists:

    Logon Optimization

    http://msdn.microsoft.com/en-us/library/aa374350(VS.85).aspx

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by PatMCT Monday, March 14, 2016 1:27 PM
    Monday, March 14, 2016 7:07 AM
    Moderator

All replies

  • Hi,

    Thanks for your post.

    Based on my experience, the issue seems to be caused by a delay in initializing network and locating domain controllers. Enabling "Always wait for the network at computer startup and logon" via group policy should resolve it as we need to give system more time to initiate network before proceeding with the logon process.

    We could also enable "Startup Policy Processing Wait Time" and setting wait time to an appropriate value to let the software installation GPOs working with minimal boot delays. We could know the accurate policy processing time via the Group Policy Operational Log Event. Please refer to the following article to get more details:

    Optimizing Group Policy Performance

    https://technet.microsoft.com/en-us/magazine/2008.01.gpperf.aspx


    There are two ways to enable this option:

    Group Policy
    Computer Configuration > [Policies] > Administrative Templates > System >Group Policy > Startup Policy Processing Wait Time – Enable the option and set wait time to 10 - 60 seconds
    Note 1: This option is only supported by Windows Vista and later clients and may be not present on Server 2003 domain controllers
    Note 2: Group policy description tells that the default wait time is 30 seconds, which obviously raises the question how setting time-out to less than 30 seconds can fix the problem. It seems that default 30 seconds interval is not always used and Windows often employs its own algorithms to calculate the time-out (if it's not enforced by Group Policy or Registry)

    Registry
    On Client Computer:

    1. Start > Regedit.exe

    2. Navigate to  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

    3. Create New DWORD value with name GpNetworkStartTimeoutPolicyValue and set Value data (decimal) to the required timeout interval in seconds

    4. Restart the computer

    Hope the above information is helpful to you.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 10, 2016 3:15 AM
    Moderator
  • Thanks for your answer !

    "Enabling "Always wait for the network at computer startup and logon" via group policy should resolve it as we need to give system more time to initiate network before proceeding with the logon process.
    ...
    We could also enable "Startup Policy Processing Wait Time" and setting wait time to an appropriate value to let the software installation GPOs working with minimal boot delays."

    ---

    I try the two GPO but i got the same result ... (the need to log twice)

    I made some more try and post again ...



    Sunday, March 13, 2016 7:12 PM
  • Hi,

    It may be related to the Fast Logon Optimization, please try to disable it and check if the issue persists:

    Logon Optimization

    http://msdn.microsoft.com/en-us/library/aa374350(VS.85).aspx

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by PatMCT Monday, March 14, 2016 1:27 PM
    Monday, March 14, 2016 7:07 AM
    Moderator
  • Hi,

    It may be related to the Fast Logon Optimization, please try to disable it and check if the issue persists:

    Logon Optimization

    http://msdn.microsoft.com/en-us/library/aa374350(VS.85).aspx

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thanks Wang

    i try it on a Windows 8.1 English version and it's working !
    (I delete my first 8.1 French version of test ... so i don't know now on this version ...)

    So it's solve

    Thanks Wang !!

    Monday, March 14, 2016 1:30 PM
  • Hi,

    I am glad to hear that your issue was successfully resolved. If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 15, 2016 1:56 AM
    Moderator