none
Error accessing reporting services - DCOM RRS feed

  • Question

  • Hello, after a (somewhat) smooth installation of SCCM 2007 SP1 on Win2k8 server i'm noticing a problem accessing reporting site , i've seen this issue in a lot of tek tips sites pointing to DCOM permissions, however the fixes recommended don't seem to be working for me.



    Accessing the reporting website http://servername/smsreporting_sitecode/ displays the error message (after turning error display on):

    Navigator

    Server object error 'ASP 0178 : 80070005'

    Server.CreateObject Access Error

    /smsreporting_lbt/ReportsNav.asp , line 1046

    The call to Server.CreateObject failed while checking permissions. Access is denied to this object.

     

    and logs the following on System Event Viewer:

     

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
    {2D527A8C-A4B6-4E74-A63F-E867360D401C}
     to the user domain\user SID (S-1-5-21-950096678-2834088623-955418618-38307) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

     

     

    The CLSID {2D527A8C-A4B6-4E74-A63F-E867360D401C} according to the registry refers to SMSRPH , i've tried adding local launch and local activation permissions, to the smsreporting users, dcom users and even everyone. But i still get the same error.

     

    If it's any use, this is the line from Reportsnav.asp:

     

    Set myReporting = Server.CreateObject("SMSRPHost.SMSReporting")
    ConnectionStatus = myReporting.Connect(Session("SMSSiteCode"), Session("SQLMachine"), _
        Session("SQLDatabase"), Session("DBConnectionTimeout"), Session("DBCommandTimeout"))

     

     

    Could anyone try to give some tips?

     

    Thanks in advance,

     

    BQ

    Thursday, April 30, 2009 4:09 PM

Answers

All replies

  • Just for future reference, after i disabled User Account Control in Control Panel/User Accounts , it got fixed.
    Thursday, May 7, 2009 3:32 PM
  • Hi,

    I was having the exact same problem but solved it by adding 'Authenticated Users' to the local 'SMS Reporting Users' group on the SCCM Server.

    Eddie.
    Wednesday, February 3, 2010 1:04 AM
  • i have the same issue~~
    i have to restart the server to fix the problem!!!!

    I have tried to add 'Authenticated Users' , not work

    Monday, June 30, 2014 3:36 AM