Marvell Libertas 802.11 b/g Wireless Lan Card RRS feed

  • Question

  • I have a wireless lan PCI card and i installed and booted vista for the first time. installed flawlessly worked and i picked up my wireless network. I rebooted for whatever reason and my network was not being detected i checked the drivers in device manager and it had an exclamation mark next to the wireless card driver. I open it up and get error code 10 cannot start. So i start doing some research and find out everyone with this card on 64 bit vista has the same problem and one person's fix was to load windows in f8 mode disable driver signing enforcement. So i give it a shot and sure enough it worked. I rebooted to test this theory back in the disabled driver signing enforcement and bam code 10 once again. i reboot once more into normal mode and then the driver is working again with no code 10 and it detects networks. and now it takes 100 tries just to get it to work so now i am feering the reboot everytime i get it to work PLEASE HELP!!! soo far all vista live support has been able to do was get me to attempt to find other drivers by doing the automatic driver search on the hardware id in device manager. No such luck there, hopefully i will have better help here! card worked fine in xp and 98 boxes i have set up at my hosue
    Wednesday, May 2, 2007 10:59 PM

All replies

  • no one?
    Friday, May 4, 2007 6:49 AM
  • I have the same problem, however I'm using 32-bit Vista.  My card used to work for the past month or so since I got Vista, but now all of a sudden it gave me the same problem you mentioned.  I've been trying to force it to use my manufacturer drivers, even though they're older, but no luck yet.  It doesn't help that the latest drivers from ASUS are for XP/2003.  I'll try to get back to you if I find a solution (and I find this thread again).  I think right now, the only thing is to hope that your manufacturer has updated Vista drivers, because I don't know when Vista will update with they're own.
    Monday, July 30, 2007 5:11 PM
  • Update the motherboard BIOS. Someone said that worked.


    Monday, July 30, 2007 6:32 PM
  • Hello Ticko311,

    I had the same problem. After the installation everything worked OK. After the first reboot the wireless lan card (Marvell Libertas 802.11 b/g Wireless Lan Card) ceased to be recognised.
    In my case the problem was the incompatibility with the PCI TV Tuner (MSI TV@Anywhere).
    The logic should be that: if you have more than one PCI card one might create conflicts. After rebooting all the devices went active so the conflict. I think it can even be a matter of the motherboard that don't manages the devices the correct way. An upgrade of the BIOS might help too.
    I have removed both TV Tuner and wireless card and rebooted, turned downd the PC  then I inserted the WIFI card. Rebooting, everything worked fine. Now I am not using the tuner anymore.

    Anyway, here you'll find the latest Marvel Libertas drivers:
    My PC is:
    motherboard : ABIT GD8 Pro
    CPU: Intel Celeron 775 (2.53 GHz)
    Graphic Card. Asus EN6200TC
    Hard disk SATA

    Hope it helps


    Saturday, August 4, 2007 9:47 AM
  • I have found the solution it's related to signed unsigned drivers. Finally works :)
    • Edited by m4lkor Monday, September 26, 2011 11:49 AM
    Monday, September 26, 2011 11:46 AM
  • The NT6x driver for this wireless chipset is buggy, install XP driver from this link:

    Sunday, April 13, 2014 1:25 PM
  • The NT6x driver for this wireless chipset is buggy, install XP driver from this link:

    yup, the NT6x drivers MRVW13B.SYS (for 32bit Windows) & MRVW13C.SYS (for 64bit Windows) were poorly written by Marvell and they were also used on the Netgear WG311V3 Wireless LAN PCI Adapter Card, which also produced almost frequent "Code 10" errors on Vista.  on the other hand, the Win2000/XP/2003 based Marvell WLAN drivers worked flawlessly.

    a more permanent fix is the replace that Marvell Libertas 802.11 b/g WLAN card with a new one that supports 802.11n (like D-Link DWA-548 or Linksys WMP600N).  those adapters use Ralink WLAN drivers and are far more reliable to work on Vista, 7 and 8 (and never produce Code 10 errors of course).  a "hardware" fix is much better than using "unsigned" and buggy Marvell WLAN NT6x drivers.

    Monday, June 2, 2014 4:26 AM