locked
All programs forced to use same default program RRS feed

  • Question

  • I have an hp laptop with Windows 7. Yesterday, when I selected a default program to open some files, I think I accidentally hit "Windows Media Center" and all my installed programs suddenly had Windows Media Center as the default program. This happens with any program I select. Now I can't open anything, as the programs don't recognize the one default program. How do I fix this? I even tried opening the "Restore My computer", but it also led to the same problem. Note that I am talking about the programs not the files. That is there is no problem with the files since I tried the feature "open with" and it worked perfectly with them, but not with the programs such as IE, Excel, Woed, Adibe....etc. Please help...

    • Moved by Helen Zhou Monday, July 12, 2010 1:48 AM (From:Windows Forms General)
    Saturday, July 10, 2010 8:07 PM

Answers

  • Hi,

     

    You need to remove the UserChoice association for exe files from the registry. Before modifying the registry, I suggest backup the registry first. Here is how to.

     

    Copy the text in the following code block into Notepad.

    Save it on the desktop with a .reg extension. Be sure to change the Save as Type: box to All Files when saving.

     

    Code:

     

    Windows Registry Editor Version 5.00

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\UserChoice]

     

    Then double click the file to merge it into the Registry.

    Click Yes in the prompt to confirm.

    You should get a Success message, click OK.

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Magon Liu Monday, July 19, 2010 1:59 AM
    Tuesday, July 13, 2010 9:48 AM

All replies

  • This is a place for windows forms programmers, definitly the wrong place for this, you'll have a better chance for an answer on the windows 7 section of the technet forums
    Saturday, July 10, 2010 8:30 PM
  • Hi,

     

    You need to remove the UserChoice association for exe files from the registry. Before modifying the registry, I suggest backup the registry first. Here is how to.

     

    Copy the text in the following code block into Notepad.

    Save it on the desktop with a .reg extension. Be sure to change the Save as Type: box to All Files when saving.

     

    Code:

     

    Windows Registry Editor Version 5.00

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\UserChoice]

     

    Then double click the file to merge it into the Registry.

    Click Yes in the prompt to confirm.

    You should get a Success message, click OK.

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Magon Liu Monday, July 19, 2010 1:59 AM
    Tuesday, July 13, 2010 9:48 AM
  • I cant open Registry Editor or any other porgrams only some kind like Winrar etc. Please help me.
    Monday, March 12, 2012 5:04 PM