locked
Edge browser hosts file RRS feed

  • Question

  • Hello, does anyone know how edge resolves the addresses?

    Context: for development purposes, I configured local aliases in hosts file (127.0.0.1 <workalias>) so I can simulate different servers (in clear, IIS sites).

    I can test with IE 11 & Chrome, they correctly read the hosts file and let me browse my websites.

    Edge just never finds <workalias>. Where does Edge find its configuration?

    Regards,

    Fauberon

    Thursday, July 30, 2015 4:26 PM

Answers

All replies

  • Fauberon,

    Well it is hard for me to tell why Microsoft Edge don't look up the hosts files like the other browser.

    Microsoft Edge actually is a built-in Universal Windows app, this fundamentally changes the process model, so that both the outer manager process, and the assorted content processes, all live within app container sandboxes.

    As hosts file is considered as the important system file, I suspect there should be some limitation for the apps to access it.

    More information, please check: Microsoft Edge: Building a safer browser

    And New Microsoft Edge and IE blog site: http://blogs.windows.com/msedgedev/

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, July 31, 2015 5:33 AM
  • Just noticed the same thing could not browse a website from iis manager

    had to change the default browser back to IE  to browse from iis

    can open http://website1 in IE, buy not edge

    host file

    127.0.0.1       localhost
    ::1             localhost

    127.0.0.10  website1


    wab

    Friday, July 31, 2015 3:10 PM
  • FYI edge doesn't like Silverlight either

    <sub></sub><sup></sup><strike></strike>works in IE but not Edge

    http://windows.microsoft.com/en-US/windows7/Change-how-buttons-appear-on-the-taskbar


    wab

    Sunday, August 2, 2015 12:27 AM
  • FYI edge doesn't like Silverlight either

    Silverlight is ActiveX, an add-on, so not standard.   Switch to IE to try to do non-standard things.


    Robert Aldwinckle
    ---

    • Proposed as answer by Michael_LS Monday, August 3, 2015 2:42 AM
    • Marked as answer by Deason Wu Monday, August 10, 2015 9:07 AM
    Sunday, August 2, 2015 4:17 AM
  • Hi

    I have noticed the same thing. However, I was able to get Edge to work by using a host name that is a FQDN. For example, mysite.mytest.com. I can't say I understand why at this point.

    Brian

    Friday, August 14, 2015 4:18 PM
  • was able to get Edge to work by using a host name that is a FQDN


    Sounds like you are trying to use a single word Intranet identifier without a protocol prefix.  In IE you would need to activate an Advanced option to that effect.  I don't know if the same option applies to Edge or not.


    Robert Aldwinckle
    ---

    Friday, August 14, 2015 5:18 PM
  • Hi Michael,

    I basically fully agree with security requirements, and hosts file (in a protected system location) may be an attack axis for xss or ssl tricks, so this could be the reason.

    Nevertheless 1), in a company environment, there is a need for developpers to test configurations on local computers, etc and DNS would be a difficult way to achieve such things. Well, I believe I will look at the local iisexpress feature, if there are not too much limitations.

    Nevertheless 2), companies basically uses proxypac configuration, and so on... how Edge will be used in such environment?

    thanks for having looked to this.

    Fauberon

    Friday, August 14, 2015 9:56 PM
  • Hello all,

     I finally found some more information about Edge here:

    https://technet.microsoft.com/fr-fr/library/mt270204.aspx; It describes settings that administrators can apply to configure Edge. They are not that much capabilities, and the most relevant are the 2 last ones: "Allows you to configure the Enterprise site list" (set the intranet sites list so they will be open in IE11) and/or "Send all intranet traffic over to Internet Explorer" (means (IE11).

    So basically, my needs are answered by... using IE11 or some other browser.

    Friday, August 14, 2015 10:22 PM
  • Hi.

    if you're trying to access localhost, you may find it blocked as a security measure. in Edge, type about:flags into the address bar and turn ON 'Allow localhost loopback (this might put your device at risk)'

    Regards...


    Mark Feetham Senior Program Manager Internet Explorer Product Quality

    Tuesday, September 8, 2015 6:19 PM
  • So, modifying the host file works to a fully qualified address like www.mysite.com mapping to 10.0.0.112 works.

    But you are trying to map to localhost 127.0.0.1 and that doesn't work correct? Or are you trying to use just one word like http://mysite and that is what doesn't work?

    Tuesday, September 8, 2015 6:48 PM
  • I can confirm that using a single word alias, MS Edge will not load it. This is what worked for me in MS Edged;

    Changing from kshabazz - to - loc.kshabazz.net

    In my host file I have:

    # Does not work with MS Edge

    127.0.0.1   kshabazz

    #Works for MS Edged, IE 11, and Mozilla Firefox

    127.0.0.1   loc.kshabazz.net


    • Edited by b01 Sunday, October 4, 2015 7:36 PM Long winded.
    • Proposed as answer by Tushar G. Walavalkar Sunday, October 11, 2015 4:04 AM
    Sunday, October 4, 2015 7:36 PM
  • I can confirm that using a single word alias, MS Edge will not load it.


    Even with a protocol prefix?  E.g.  http://kshabazz/


    Robert Aldwinckle
    ---

    Sunday, October 4, 2015 9:10 PM
  • But you are trying to map to localhost 127.0.0.1 and that doesn't work correct? Or are you trying to use just one word like http://mysite and that is what doesn't work?

    Yes and Yes.

    Same as I always have, in any other browser, anywhere, ever.

    Microsoft, fix this - if you want developers to target your new browser, stop throwing up roadblocks!

    At least give us an option to turn off this idiotic "security measure" - developers don't need training wheels!

    Monday, November 23, 2015 9:55 AM
  • Yes, even with a protocol prefix. Edge does not resolve local hostnames normally.

    Fix it.

    Monday, November 23, 2015 9:56 AM
  • 1 Open the Control Panel -> Internet Options dialog

    2 Go to the Security tab

    3 Select 'Local intranet' zone and click "Sites" button.

    4 Check the 'Automatically detect intranet network' box.

    Edge can now find any local website using 127.0.0.1 loopback and "hosts" file (including single word ones). Please notice using protocol prefix is obligatory!!!


    Ziggi


    • Edited by Ziggizag Wednesday, November 25, 2015 7:52 PM
    Wednesday, November 25, 2015 7:49 PM
  • Also, if there is a reverse proxy (TMG) on the network:

    1 Open the Control Panel -> Internet Options dialog

    2 Go to the Connections tab > LAN Settings

    3 Uncheck "Automatically Detect Settings"

    Now both Edge and IE can resolve hostnames (using Win10 v1607).


    • Edited by Kurt B. Mayer Thursday, September 22, 2016 10:26 PM Revise
    Thursday, September 22, 2016 10:25 PM
  • None of the listed fixes work for me. I'm using a VirtualBox VM running through Vagrant. Edge just utterly ignores hosts which is a huge hold back for developers trying to test. It means minor changes have to be deployed to a staging server to test.

    Microsoft is trying really hard in most regards to get back in developers good books. This is a pretty huge setback in that regard.

    Tuesday, November 29, 2016 3:19 PM
  • It would seem it doesn't entirely ignore the host file, it can read it and know it needs to do something different it just doesn't know what. We use the host file to swap to our local machines, so without the host entry it goes to a shared location with the host entry it goes to our local machine.

    When I have no entry in the host file it goes to the shared location, however if I put in a host entry it goes no where. This implies that it know it needs to go to a different address it just cant get there.

    I have also found that if I log onto my machine using my network login the host file does work, however if I log in using a local account then it does work. So I think there must be a permission issue somewhere blocking my network account.

    Wednesday, December 14, 2016 4:29 PM
  • think there must be a permission issue somewhere blocking my network account.

    I wonder if it is related to Local Loopback Exemption?  Fiddler4 has a tool which we can use to control that.

    https://blogs.msdn.microsoft.com/fiddler/2011/12/10/revisiting-fiddler-and-win8-immersive-applications/



    Robert Aldwinckle
    ---

    Wednesday, December 14, 2016 8:29 PM
  • This has worked for me!

    I downloaded the standalone version of the EnableLoopback Utility from the above link, installed it, ticked Edge, and saved changes. Now my host file is working with Edge.

    Please note I have tried other things so this could be a combination of fixes, which I believe are all on this post.

    Thursday, December 15, 2016 11:08 AM
  • think there must be a permission issue somewhere blocking my network account.

    I wonder if it is related to Local Loopback Exemption?  Fiddler4 has a tool which we can use to control that.

    https://blogs.msdn.microsoft.com/fiddler/2011/12/10/revisiting-fiddler-and-win8-immersive-applications/



    Robert Aldwinckle
    ---

    Thanks. That worked for me with Windows 10 Enterprise x64 and Edge.
    Monday, August 28, 2017 1:46 PM
  • This solution worked for me. Edge would not resolve a hostname in my network till I applied this solution.  IE had no problems with the hostname with or without this solution.  I will add that the hostname that I wanted resolved is not in the /windows/system32/drivers/etc/HOSTS file.  The name is resolved through a WINS server which I need so that I can access windows shared files from a Linux host in my network using NetBIOS names.  So checking "Automatic detect intranet network' also enables the use of WINS for edge. 

    Thursday, August 29, 2019 12:37 AM