locked
Get-AppvClientPackage and Mount-AppVClientPackage fail during Task Sequence RRS feed

  • Question

  • Hi folks, We are attempting to pre-cache and pre-mount our app-v 5.1 applications on clients during a task sequence. Randomly, it fails with the error "AppVStreamingUX.exe - Application Error - The exception unknown software exception (0x0434352) occurred in the application at location 0x000007FFF4AB99E08." Seems to happen randomly on different packages.

    Using SCCM CB 1702, Windows 10 x64 Ent 1703, App-V 5.1 (built-in client).

    Any ideas? 

    Thanks,

    Kevin

    Friday, September 29, 2017 6:09 PM

All replies

  • Hi Kevin,

    We also faced the same issue in our environment because the task Sequence cache gets removed from the machine as soon as the installation gets completed. We mounted the package as a last step in Task Sequence and till then the cache was gone from the machine for mounting.

    Solution:

    1. Use the single liner

    Add-AppVClientPackage {PkgName} | Publish-AppvClientPackage -Global | Mount-App-VClientPackage

    2. Copy the package first to some temporary location (like C:\Windows\temp) on the machine with the installation script and then install the package from there.

    3. Integrate the Virtual application as an application model since it automatically mounts it during installation.

    Regards,

    Mohit Kapoor


    • Edited by Mohit Kapoor Monday, October 2, 2017 11:22 AM
    • Proposed as answer by Mohit Kapoor Tuesday, December 26, 2017 3:37 PM
    Monday, October 2, 2017 10:59 AM
  • Thanks for the suggestion, Mohit. We will try that and report back.
    Monday, October 2, 2017 2:16 PM