locked
Invalid Server name RRS feed

  • Question

  • Hi.

    Mi name is Christian.

    I have a problem when I try to set the server PAS on Proclarity Web part ,I receive the next error: INVALID SERVER NAME.

    My Enviroment is this:

    Proclarity Server
    - Windows and basic authentication on the PAS site
    - Site http://ProclarityServername:85

    SharePoint Server
    - MOSS 2007
    - Proclarity web installed.

    Here some test steps that I have realized:
    - A ping from SharePoint Server to ProclarityServer is working
    - ProclarityServer in port 85 is accesible via telnet from Sharepoint Server
    - I reviewed "ProClarity Viewer Web Part for SharePoint User Guide" ProClaritySharePointViewer_6_3_136_300 and the webpart is correctly installed
    - Changes to web page are maded via Sharepoint Administrator user, this user has a certificated installed in IExplorer.
    - Accesing PAS site from Sharepoint Server is working using PAS administrator Account(Impersonating Iexplorer with this Pas admin user)
    - A Previus published Sharepoint page is working with the webpart, but when I create a new page with the webpart I receive the message Invalid Server name.
    - I try publishing the Sharepoint page with other administrator user of the SharePoint site , and the error message is the same.
    - I try with url http://ProclarityServername:85/en/src too, same error.
    - I have compared the hotfix file PDefaultPage.asp with the file that I have, but since I have installed Proclarity Service Pack 2 the content of this file is updated.

    Please, can you help me with this error?

    Thanks.

    Christian.
    Monday, March 30, 2009 4:10 PM

Answers

  • Hi everybody.

    I worked with Sean ton solve this problem in one client, the solutions were:

    ·        Problem:  ProClarity webpart for SharePoint is unable to connect to a PAS server – error appears in red “Invalid server name”

    o   The web part was working previously and then stopped working.  ProClarity views that were previously added to MOSS are still working

    o   ProClarity web part works when IIS authentication is set to use a specific user account (anonymous access set to a user with sufficient access to the library).  This indicated a problem with authentication itself

    o   A packet trace identified showed the issue as:  MOSS server sends an HTTP GET request to http://passerver/pas; PAS sends back a 401 challenge response; PAS server sends a TCP ACK+PUSH to MOSS, which MOSS replies with an ACK.  When working, the MOSS server will first send an HTTP GET request and then an HTTP POST request for PSTORE.ASP.  The second HTTP request simply was not being sent with no errors indicating the failure point.

    o   A subcase was opened with the IIS team for collaboration in troubleshooting the authentication issue.  The IIS team could not find any problems or indication of why the failure was occurring

    o   A second PAS and MOSS server were brought online in your environment.  The same problem was present when testing with the new servers.  IIS and IE settings were ruled out as possible causes

    o   The OS language and MOSS localized version were investigated and ruled out as a possible cause

    o   Obtained a list of software installed on each MOSS server and tested the web part internally on a server with matching configuration

    o   Built matching test server piece by piece and repro’d the issue after installing the language pack for .NET 2.0 SP2

    ·        Cause:  A conflict exists between the ProClarity web part and ‘Microsoft .NET Framework 2.0 Service Pack 2 Language Pack – ESN’

    o   The same problem exists with all .NET 2.0 SP2 language packs, and not just Spanish

    o   The language pack for .NET 2.0 and .NET 3.1 does not cause an issue, only the language pack for .NET 2.0 SP2

    o   Web part appears to be unable to read the .NET information with the SP2 language pack when Basic or Integrated authentication are used

    ·        Solution1:  Uninstall ‘Microsoft .NET Framework 2.0 Service Pack 2 Language Pack – ESN’ and reboot.  If problems persists, repair/reinstall the .NET 2.0 Framework

    ·        Solution2:  Add ProClarity views to MOSS using the two workaround methods discussed in the case

    o   Workaround1:  Manually add the ProClarity views to MOSS.  Each ProClarity view has a unique URL that can be used to access it.  Essentially what the ProClarity web part does is obtains the URL for a ProClarity view, adds parameters to the end of the URL corresponding to the options selected in the web part ‘ProClarity View Options’ settings, and then publishes that URL as a standard ‘Page Viewer’ web part

    ·        Open the ProClarity view in a browser that you’d like to add to the SharePoint page.  Copy the URL from the address bar

    ·        On the MOSS page, create a Page Viewer web part, specify a ‘Web Page’ and paste the link into the ‘Link’ section

    ·        Add the appropriate parameters to the end of the URL.  The individual settings correspond to the follow parameters:

    o   Default parameters:

    §  &fullscreen=true (full Screen)

    §  &tabsVisible=false (removes menus)

    o   Layout:

    §  Chart only:                                          &Layout=Single1

    §  Grid only:                                            &Layout=Single2

    §  Chart above grid:                             &Layout=SplitVert

    §  Chart to the left of grid:                &Layout=SplitHorz

    o   Show:

    §  View title is checked:                     &pageTitleVisible=true

    §  Function tabs is checked:             &ContentNavigation=true

    o   Interactivity:

    §  Allow view interaction checked:                &dimToolVisible= true

    §  Allow view interaction not checked:        &dimToolVisible= false

    §  Allow content navigation checked:          &isStatic=false

    §  Allow content navigation not checked:  &isStatic=true

    §  Allow to open view in full checked:          &fullScreen=true

    §  Allow to open view in full not checked:  &fullScreen=false

    ·        The default for the web part is ‘Chart only, View title, allow view interaction, navigation, and to open view in full.  The corresponding URL would be constructed as:  http://passerver/URL&Layout=Single1&ContentNavigation=true&DimToolVisible=false&fullScreen=true&isStatic=false&TabsVisible=false&pageTitleVisible=true

    o   Workaround2:  Switch the PAS authentication to ‘Anonymous’ and set the credentials to a user that has access to the PAS libraries.  Add the ProClarity views to MOSS using the web part and then switch authentication back to Basic or Integrated

    And finaly I use the switch PAS autentication to Anonymous..

    Good luck.
    Christian.

    • Marked as answer by Sean_Flanagan Wednesday, September 16, 2009 3:15 PM
    Monday, September 14, 2009 10:02 AM

All replies

  • This is probably a bit of a silly question, but have you tried http://proclarityserver:85/pas (or whatever the PAS virtual directory is named)?
    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, April 1, 2009 9:02 PM
  • Hi Ben.

    Yes, I tried with this url, same error = "Invalid server name".

    Thanks for your interest.

    Christian
    Tuesday, April 7, 2009 8:55 AM
  • Hi Christian,

    So you're saying that you can successfuly navigate to the PAS URL independant of Sharepoint?  When you navigate to http://PASServerName:85/pas you can see the ProClarity Web Standard interface?  Yet this same URL is not working within the Webpart configuration?  What if you specify the IPAdress rather than Servername (http://IPAddress:85/pas)?  If you disable friendly HTTP error messaging in IE do you receive further information about the error?  And what about the IIS Logs and Event Logs, anything in either of those?

    Regards,
    Amanda
    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, April 8, 2009 11:36 PM
  • Hi,

    I have the same problem on my server : I can access the http://Proclarityserver/PAS url directly in my IE, but when I use this URL for the "Proclarity Analytics server" in the sharepoint webpart, I have the "Invalid server name" error message :-(

    Christian, did you finallly solve your problem?

    Thanks a lot in advance,

    Fanny
    Thursday, July 23, 2009 9:07 AM
  • One thing that is known to cause this problem is a .NET language pack.  If you check in add/remove programs do you see any .NET language packs installed?
    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, July 24, 2009 10:11 PM
  • Hi Sean,

    Thanks for your answer.

    I have checked in add/remove programs and found :
    Microsoft .NET Framework 2.0
    Microsoft .NET Framework 3.0
    Paint .NET v3.36

    Could it cause some problems?

    Fanny

    Tuesday, July 28, 2009 9:50 AM
  • Hi Fanny,

    I don't think that the standard .net frameworks will cause an issue.  I haven't tested Paint .NET however .net language packs are a known issue for conflicting with the authentication mechanism in the PAS webpart.  There are basically two workarounds if the problem persists... #1 is to switch the directory security for PAS to Anonymous, add the views using the webpart, and then switch security back to normal.  The other option is to build the URL manually.  The ProClarity webpart is basically just a Page Viewer Web Part and a series of check boxes which when checked append URL parameters to manipulate the PAS view you're linking to.  You can manually build the PAS url and then use the Page Viewer webpart instead:

    ·          Open the ProClarity view in a browser that you’d like to add to the SharePoint page.  Copy the URL from the address bar

    ·          On the MOSS page, create a Page Viewer web part, specify a ‘Web Page’ and paste the link into the ‘Link’ section

    ·          Add the appropriate parameters to the end of the URL.  The individual settings correspond to the follow parameters:

    o    Default parameters:

    §   &fullscreen=true (full Screen)

    §   &tabsVisible=false (removes menus)

    o    Layout:

    §   Chart only:                                          &Layout=Single1

    §   Grid only:                                            &Layout=Single2

    §   Chart above grid:                             &Layout=SplitVert

    §   Chart to the left of grid:                &Layout=SplitHorz

    o    Show:

    §   View title is checked:                     &pageTitleVisible=true

    §   Function tabs is checked:             &ContentNavigation=true

    o    Interactivity:

    §   Allow view interaction checked:                &dimToolVisible= true

    §   Allow view interaction not checked:        &dimToolVisible= false

    §   Allow content navigation checked:          &isStatic=false

    §   Allow content navigation not checked:  &isStatic=true

    §   Allow to open view in full checked:          &fullScreen=true

    §   Allow to open view in full not checked:  &fullScreen=false

    The default for the web part is ‘Chart only, View title, allow view interaction, navigation, and to open view in full.  The corresponding URL would be constructed as:  http://passerver/URL&Layout=Single1&ContentNavigation=true&DimToolVisible=false&fullScreen=true&isStatic=false&TabsVisible=false&pageTitleVisible=true:


    Hth,
    Sean

    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, July 28, 2009 2:31 PM
  • Hi everybody.

    I worked with Sean ton solve this problem in one client, the solutions were:

    ·        Problem:  ProClarity webpart for SharePoint is unable to connect to a PAS server – error appears in red “Invalid server name”

    o   The web part was working previously and then stopped working.  ProClarity views that were previously added to MOSS are still working

    o   ProClarity web part works when IIS authentication is set to use a specific user account (anonymous access set to a user with sufficient access to the library).  This indicated a problem with authentication itself

    o   A packet trace identified showed the issue as:  MOSS server sends an HTTP GET request to http://passerver/pas; PAS sends back a 401 challenge response; PAS server sends a TCP ACK+PUSH to MOSS, which MOSS replies with an ACK.  When working, the MOSS server will first send an HTTP GET request and then an HTTP POST request for PSTORE.ASP.  The second HTTP request simply was not being sent with no errors indicating the failure point.

    o   A subcase was opened with the IIS team for collaboration in troubleshooting the authentication issue.  The IIS team could not find any problems or indication of why the failure was occurring

    o   A second PAS and MOSS server were brought online in your environment.  The same problem was present when testing with the new servers.  IIS and IE settings were ruled out as possible causes

    o   The OS language and MOSS localized version were investigated and ruled out as a possible cause

    o   Obtained a list of software installed on each MOSS server and tested the web part internally on a server with matching configuration

    o   Built matching test server piece by piece and repro’d the issue after installing the language pack for .NET 2.0 SP2

    ·        Cause:  A conflict exists between the ProClarity web part and ‘Microsoft .NET Framework 2.0 Service Pack 2 Language Pack – ESN’

    o   The same problem exists with all .NET 2.0 SP2 language packs, and not just Spanish

    o   The language pack for .NET 2.0 and .NET 3.1 does not cause an issue, only the language pack for .NET 2.0 SP2

    o   Web part appears to be unable to read the .NET information with the SP2 language pack when Basic or Integrated authentication are used

    ·        Solution1:  Uninstall ‘Microsoft .NET Framework 2.0 Service Pack 2 Language Pack – ESN’ and reboot.  If problems persists, repair/reinstall the .NET 2.0 Framework

    ·        Solution2:  Add ProClarity views to MOSS using the two workaround methods discussed in the case

    o   Workaround1:  Manually add the ProClarity views to MOSS.  Each ProClarity view has a unique URL that can be used to access it.  Essentially what the ProClarity web part does is obtains the URL for a ProClarity view, adds parameters to the end of the URL corresponding to the options selected in the web part ‘ProClarity View Options’ settings, and then publishes that URL as a standard ‘Page Viewer’ web part

    ·        Open the ProClarity view in a browser that you’d like to add to the SharePoint page.  Copy the URL from the address bar

    ·        On the MOSS page, create a Page Viewer web part, specify a ‘Web Page’ and paste the link into the ‘Link’ section

    ·        Add the appropriate parameters to the end of the URL.  The individual settings correspond to the follow parameters:

    o   Default parameters:

    §  &fullscreen=true (full Screen)

    §  &tabsVisible=false (removes menus)

    o   Layout:

    §  Chart only:                                          &Layout=Single1

    §  Grid only:                                            &Layout=Single2

    §  Chart above grid:                             &Layout=SplitVert

    §  Chart to the left of grid:                &Layout=SplitHorz

    o   Show:

    §  View title is checked:                     &pageTitleVisible=true

    §  Function tabs is checked:             &ContentNavigation=true

    o   Interactivity:

    §  Allow view interaction checked:                &dimToolVisible= true

    §  Allow view interaction not checked:        &dimToolVisible= false

    §  Allow content navigation checked:          &isStatic=false

    §  Allow content navigation not checked:  &isStatic=true

    §  Allow to open view in full checked:          &fullScreen=true

    §  Allow to open view in full not checked:  &fullScreen=false

    ·        The default for the web part is ‘Chart only, View title, allow view interaction, navigation, and to open view in full.  The corresponding URL would be constructed as:  http://passerver/URL&Layout=Single1&ContentNavigation=true&DimToolVisible=false&fullScreen=true&isStatic=false&TabsVisible=false&pageTitleVisible=true

    o   Workaround2:  Switch the PAS authentication to ‘Anonymous’ and set the credentials to a user that has access to the PAS libraries.  Add the ProClarity views to MOSS using the web part and then switch authentication back to Basic or Integrated

    And finaly I use the switch PAS autentication to Anonymous..

    Good luck.
    Christian.

    • Marked as answer by Sean_Flanagan Wednesday, September 16, 2009 3:15 PM
    Monday, September 14, 2009 10:02 AM