locked
[SOLVED] - Open Windows Explorer Redirect to Computer vs Libraries RRS feed

  • Question

  • When you right click on the Start Menu and select 'Open Windows Explorer', it, by default, takes you to 'Libraries' location.  Is there any chance this can be modified to redirect to a specific location, like 'Computer' or 'C:\' instead?

    FYI - Disabling Libraries completely breaks the 'Open Windows Explorer' menu option.  After clicking on it, nothing happens.

    • Edited by JuliusPIV Wednesday, February 16, 2011 1:02 PM
    Friday, June 18, 2010 8:13 PM

Answers

  • When you right click on the Start Menu and select 'Open Windows Explorer', it, by default, takes you to 'Libraries' location.  Is there any chance this can be modified to redirect to a specific location, like 'Computer' or 'C:\' instead?

    FYI - Disabling Libraries completely breaks the 'Open Windows Explorer' menu option.  After clicking on it, nothing happens.

    The right click Open Windows Explorer is not a good way to open WE, since that link is hard coded to open in the Libraries and you cannot configure that option. This is why removing the Libraries breaks that link.

    You need to either pin Windows Explorer to the Start Menu or the Taskbar. Once you do this, you can right click that shortcut and select Properties. In the Target Box, enter the following.

    %windir%\explorer.exe e, c:

    Click Apply/OK.

    Hope this helps.

    Thank You for using Windows 7


    Ronnie Vernon MVP
    • Marked as answer by JuliusPIV Friday, June 25, 2010 2:58 AM
    Saturday, June 19, 2010 1:38 PM

All replies

  • When you right click on the Start Menu and select 'Open Windows Explorer', it, by default, takes you to 'Libraries' location.  Is there any chance this can be modified to redirect to a specific location, like 'Computer' or 'C:\' instead?

    FYI - Disabling Libraries completely breaks the 'Open Windows Explorer' menu option.  After clicking on it, nothing happens.

    The right click Open Windows Explorer is not a good way to open WE, since that link is hard coded to open in the Libraries and you cannot configure that option. This is why removing the Libraries breaks that link.

    You need to either pin Windows Explorer to the Start Menu or the Taskbar. Once you do this, you can right click that shortcut and select Properties. In the Target Box, enter the following.

    %windir%\explorer.exe e, c:

    Click Apply/OK.

    Hope this helps.

    Thank You for using Windows 7


    Ronnie Vernon MVP
    • Marked as answer by JuliusPIV Friday, June 25, 2010 2:58 AM
    Saturday, June 19, 2010 1:38 PM
  • Is there any chance this can be modified to redirect to a specific location, like 'Computer' or 'C:\' instead?

    Yes, use this command line:

    %windir%\explorer.exe /n,/e,C:\

    this will set the start folder to C:\


    best regards
    André


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    • Proposed as answer by Andre.Ziegler Saturday, June 19, 2010 9:12 PM
    Saturday, June 19, 2010 9:12 PM
  • why do you think that is so?
    I have no idea. This commandline works since Windows 95. I don't know why it fails for you.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Sunday, June 20, 2010 10:26 PM
  • Hi JuliusPIV,

     

    Also, you can try the following suggestions to see if this can be resolved:

     

    1.     Go to Start, type explorer in the Start Search box.

    2.     Right click on Windows Explorer listed in the search results, and then click Properties.

    3.     Under the Target field the default value is %SystemRoot%\explorer.exe change that to:

     

    %SystemRoot%\explorer.exe /root,::{20D04FE0-3AEA-1069-A2D8-08002B30309D}

     

    Note: This opens my computer but only explores the root, child objects will open in a new window. To make it explore child objects as well use one of the below codes (recommended)

     

    %SystemRoot%\explorer.exe /e,::{20D04FE0-3AEA-1069-A2D8-08002B30309D}

     

    %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}

     

    4.     Click Apply and then click OK.

     

    Hope this helps.

     

    Regards,

    Linda

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, June 21, 2010 6:00 AM
  • To all:

    Thank you for taking the time read this post and respond to it.  I really appreciate your support and feedback.

    It seems that I may not have been clear in my original request although some did seem to understand.  To clarify, I was not looking for a method of accessing Explorer or creating a shortcut that would point to a specific location, this I can do; for instance:

    • %systemroot%\explorer.exe /n,/e,/root,%cdrom%

    In a stock Windows 7 machine (I'm using Ultimate and Enterprise for instance), if you right click on the Start orb you have two options: Properties and Open Windows Explorer.  The latter is what I'm referring to.  When you click Open Windows Explorer it opens an Explorer window that defaults to 'Libraries.'  Because we wish to disable 'Libraries', when we do so, the Open Windows Explorer option no longer works.  I was hoping it would be an easy fix via the registry, but per one of the earlier responses, that doesn't seem to be the case.

    grits n gravy: Excellent information above!  This will no doube prove useful down the road.  As you mentioned, it doesn't work in Vista, and but the first (and only test) performed tonight in Windows 7 was positive:

    • Control Panel\All Control Panel Items\Programs and Features"::{26EE0668-A00A-44D7-9371-BEB064C98683}\0\::{7B81BE6A-CE2B-4676-A29E-EB907A5126C5}"

    Thanks all.  Marking this as solved.

    Friday, June 25, 2010 3:04 AM
  • I know it's an old post and it's marked 'Solved', but I cannot see the solution and I urgently need one. There must be some information missing in the answers. Could you please describe, what you did, so that the Explorer can be opened again from the context menu after disabling the libraries? It's exactly the problem we have in rolling out Windows 7 clients.

    Thanks a lot.

    Tuesday, August 23, 2011 10:39 AM
  • Hey there Schiffsbank: Sorry for the delay - been on vacation.  This is marked as 'solved' as you pointed out, but its a bit misleading: Its 'solved' as in there is no real solution.  I received confirmation that I couldn't do what I wanted to do.  In the end we held off on disabling Libraries.

    Monday, September 12, 2011 4:47 PM
  • JuliusPIV wrote "FYI - Disabling Libraries completely breaks the 'Open Windows Explorer' menu option.  After clicking on it, nothing happens."

    Thanks so much!  I got rid of the Libraries earlier this afternoon and have been pulling my hair out ever since, wondering why on earth right-clicking on Start would get Explorer going!  Now I now.  I hope I'll read some way of getting it work again further down this thread!

    Sunday, April 1, 2012 7:07 PM
  • 'm glad that helped!  I try to update all my forum posts with relevant information *just in case* someone else has the same problem!
    Monday, April 2, 2012 11:38 PM