none
Download Content Package in OS Upgrade TS fail RRS feed

  • Question

  • Hello Guys,

    We have a OS Upgrade Task Sequence that have a Download Package Content step. This download a driver package with a WMI query as condition for Laptop Model.

    This is how we use it:

    When we are running the TS it won't download the driver package to C:\Drivers. After that the TS will fail. If i look at the smsts.log i see several errors:

    When i start the TS a second time it will download the driver package to C:\Drivers in the smsts.log you see that it is downloading the package to C:\Drivers.

    My problem is that i cannot find why the TS is not downloading the driver package to C:\Drivers the first time. I have tried to make a other TS and only place the download package content steps and run this on the laptop. This will work and it is downloading the driverpackage to C:\Drivers. But in combination with the OS upgrade TS this is not working.
    I have also tried the other two options CCM cache and TS working directory but same result.

    Who is experiencing this? Or could help me troubleshoot this? I have looked at the CAS and Datatransfer.log but no error or something else what could explain this behaviour.

    Thursday, March 14, 2019 8:18 AM

All replies

  • have you tried creating that directory before the step? or just use the option for task sequence sequence working directory, and then specify the variable as you are already doing. 

    Dan Padgett | MCSE (Mobility) | Blog: www.execmgr.net | LinkedIn: Dan Padgett | Twitter: @danjpadgett

    Thursday, March 14, 2019 10:09 AM
  • Hi Tapsee786,

    The download location Custom path requires an additional action. Step1, the task sequence will download the content to the C:\_SMSTaskSequence\Packages directory. Step2, after that it will stage the downloaded content to the custom path C:\Drivers folder and then add a numerical suffix to the variable name. 

    From the log snippet, we can see that the package CAS008A3 has already finished Step1 and downloaded to the path C:\_SMSTaskSequence\Packages\CAS008A3, but failed as Step2. Please help check if the directory C:\Drivers exists before this step. 

    Look forward to hearing from you.

    Best regards,
    Simon Ren

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 14, 2019 11:48 AM
  • Hello Dan,

    Yes, i have created the directory before running the TS, but still it wont download it. Also when i remove the condition from the step it skips. When i choose TaskSequence working directory same behaviour.

    If i remove the OS upgrade step, so only the download of the package to C:\Drivers it completed succesfully. We have used this before upgrade to Windows 10 1709, and it worked great! Now we are on SCCM 1810 and this is not working as it should.

    Thursday, March 14, 2019 12:11 PM
  • Hello Simon,

    The log snippet says it is download to _SMSTaskSequence, but the strange thing is the package didn't downloaded it. The package CAS008A3 isn't there.

    We have 18 download package steps all with wmi conditions when we runs this with de OS upgrade steps it skips al the 18 steps, no download at al.

    Tried to update the driver package, no luck. Also tried to recreat the driver package, still no luck.

    Thursday, March 14, 2019 12:17 PM