none
MDT 2013 - Capture WIM vs. Domain Join in rules.ini RRS feed

  • Question

  • Hi,

    Pre MDT2013 it was possible to have domain join settings in the rules.ini and run capture tasks.

    rules.ini ->

    JoinDomain=<my domain>
    DomainAdmin=<domain join account>
    DomainAdminDomain=<domain>
    DomainAdminPassword=<password>
    MachineObjectOU=OU=Computers Germany,OU=_Computers,OU=EU Offices,DC=bar,DC=foo,DC=com

    On MDT2013, whenever I enable my domain join settings capture task will cancel shortly upon start.

    Is this a desired behaviour?

    How are you working aroun that?

    Regards,

    Albert

    Friday, March 14, 2014 10:36 AM

Answers

  • Albert, I do not see any "Bug" here.

    There were *NO* changes made to CaptureOnly.xml, Client.xml, nor LTISysPrep.xml between MDT 2012 Update 1 and MDT 2013.

    Additionally, LTISysPrep.wsf does not make any checks for JoinDomain, instead it checks the state of the OS to determine if it is joined to a domain.

    If you are still having problems, please copy your BDD.log file to a public share like SkyDrive and post the link here.


    Keith Garner - keithga.wordpress.com

    Wednesday, March 26, 2014 11:59 PM
    Moderator

All replies

  • Yes,

    You need to make sure your build task sequence does not join the domain. You can either achieve this by disableing the recover from domain option in your task sequence.

    Create a model or tasksequence section in your customsettings.ini and then based on priority set:

    JoinWorkgroup=workgroup_name

    before the domainjoin in the default section

    Also it is possible to create a task sequence variable at the top of your task sequence called: JoinWorkgroup

    Task Sequence Variable: JoinWorkgroup

    Value: workgroup_name

    Cheers!


    If this post is helpful please click "Mark for answer", thanks! Kind regards

    Friday, March 14, 2014 2:06 PM
  • The issues here it that I want to run a "Sysprep and Capture" TS from a running VM occasionally - the VM is of cause not domain joined and it used to work like that pre MDT2012 actually.

    Most of the time I (re)deploy machines and don't want to take care of domain join settings in every deployment task sequence, so having that info in the CS.ini is very comfortable.

    And actually LTISysprep.wfs is taking care of not to sysprep a domain joined system by checking Win32_ComputerSystem/DomainRole...

    Setting JoinWorkgroup=<wg_name> in the "Sysprep and Capture" task sequence or in the CS.ini prior to JoinDomaindoes not work.

    The task returns "deployment successful" just after the configure phase.

    if I remove the JoinDoman stuff from my cs.ini the task sequence offers to specify a backup location, runs sysprep, applies PE and captures the "master image" as desired.

    I consider this behavior a bug - a "sysprep and capture" task should not take care of any domain join settings in the CS.ini as joining a domain is not part of the sequence at all.

    Wednesday, March 26, 2014 9:52 AM
  • Albert, I do not see any "Bug" here.

    There were *NO* changes made to CaptureOnly.xml, Client.xml, nor LTISysPrep.xml between MDT 2012 Update 1 and MDT 2013.

    Additionally, LTISysPrep.wsf does not make any checks for JoinDomain, instead it checks the state of the OS to determine if it is joined to a domain.

    If you are still having problems, please copy your BDD.log file to a public share like SkyDrive and post the link here.


    Keith Garner - keithga.wordpress.com

    Wednesday, March 26, 2014 11:59 PM
    Moderator
  • Albert,

    My recommendation would be to create a second Deployment Share and use that only for Build & Capture Task Sequences.

    I blogged about this a while ago, and I think it would work well for you (Build and Capture Task Sequence)

    I recommend re-building your image you want to capture each time.  This way you have a clean build with less patches on it (as the superseded patches will not be applied).

    If you don't (or can't) do this, then you should try the following:

    Assumptions

    * Task sequence is named SYSPREPCAP

    * I think from reading your previous posts that you don't want to join this to the domain, but you want all other TS's to join.

    You'll want to try this in your CustomSettings.ini file.

    [Settings]
    Priority=TaskSequenceID, Default
    
    [SYSPREPCAP]
    JoinWorkgroup=WORKGROUP
    
    [DEFAULT]
    JoinDomain=<my domain>
    DomainAdmin=<domain join account>
    DomainAdminDomain=<domain>
    DomainAdminPassword=<password>
    MachineObjectOU=OU=Computers Germany,OU=_Computers,OU=EU Offices,DC=bar,DC=foo,DC=com

    Sunday, March 30, 2014 2:14 AM