locked
AppV 5 Scripting Not Executing via Publishing Server RRS feed

  • Question

  • Hello,

    I'm experimenting with scripting inside AppV Packages and running into some strange issues. Below is an outline of what I have tried and how my environment is configured.

    Environment:

    Server:

    AppV 5 SP1 Publishing Server

    Server 2012

    Client:

    AppV 5 SP2 Hotfix 4

    Windows 7 SP1

    Configure via GPO - Relevant to this issue I have enabled Scripting on the clients and also worth mentioning I run our setup in SharedContentStore Mode (DFS for Package Source)

    Issue:

    I have been playing with scripting and have had relitivly good success in that I can configure a user or machine based scipt to run that works when test by manually adding the package via Powershell to the client. The problem is that when I deploy the exact same package to the user or machine via the publishing server it never even attempts to run the scripts, no event logs or anything relating to the script. I created a script that logs to a file if it runs and tested this via a manual add and it worked, added to the console and no luck. The package still works fine when deployed to the client, just the scripting does not appear to be running.

    Has anyone had any experience with an issue like this?

    Tuesday, July 22, 2014 12:40 AM

Answers

  • As the scripts most-likely are not part of the .app-v file, but reside in the 'externa' config.xml files, you've to tell the App-V environment that these xmls have to be used.

    Machine based deplyoment XML files can be imported as advanced properties of applications/packages; user based XMLs can be imported as advanced confgurations of AD assignments. Did you do that?


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Tuesday, July 22, 2014 7:26 AM
    Moderator