none
Web part working on server but not on client RRS feed

  • Question

  • I have a problem with the performancepoint web part. After installing the webpart we tried to deploy a dashboard to the server. The dashboard was deployed but when I view it I get the error:

    "An error occurred during the processing of . Unable to create type 'PPSWebPartsTongue TiedcriptManagerLoader'. Could not load file or assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. "

    When I try to add the web part to the site I find it in the list but get the file not found error when it comes to configuring it.

    The strange part is that when I log on to the server and open the same site op in IExplorer I can view the dashboard and configure the webpart.

    Has this something to do with .net web extensions as I have read that some people have had problems with?

    Appreciate all help on this one!

    Ásgeir Gunnarsson


    Thursday, October 9, 2008 11:48 AM

Answers

All replies

  •  

    Hello,

     

    Is .net 3.5 installed?  It isn't supported if it is. 

     

    See this thread there is some information in it regarding your issue:  http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3178687&SiteID=17

     

     

    I think you may need to install AJAX 2.0.

     

     

    Thank you,

     

    Aseem Nayar - MSFT

     

     

    Thursday, October 9, 2008 7:05 PM
  • Hi Aseem. AJAX 2.0 is installed on the server. On the server .net 3.0 with sp1 is installed so its not 3.5.

     

    The difference between my problem and the ones in the thread you pointed out is that in my case everthing work fine if I access the dashboard in browser on the server it self, but does not work on client browsers.

     

     

    Hope you can help

     

    Ásgeir

     

    EDIT. Just wanted you to know that the monitoring server is not on the same server as the SharePoint server. I have been able to deploy to the sharepoint server. I can view it on the server itself but not on the clients.

    Monday, October 13, 2008 2:30 PM
  • Is .net 3.5 on the workstations?  Also what version of IE are you running ont he workstations? 

     

    Thanks,

     

    Aseem Nayar - MSFT

    Monday, October 13, 2008 4:10 PM
  • Yes 3.5 is installed on the workstations. We are using IE 7.0.5730.13.

     

    I tried to uninstall .net 3.5 on my workstation but that did not solve the problem.

     

    I can connect to Dashboard Designer without a problem and deploy the dashboards.

     

    Do you think its worth the try to uninstall the PPS component from our SharePoint machine and install it again?

     

     

    This is getting really frustrating!

     

    Ásgeir

    Tuesday, October 14, 2008 7:58 AM
  • I wonder if our best bet might be to install .NET 3.5 on the server and update all the web.config files. It seems to have worked for many people according to the other tread you pointed out to me?

     

    What troubles me is the difference in their problem and ours, that is that our works on the server but not on the workstations.

     

    Tuesday, October 14, 2008 8:33 AM