locked
Save Site As A Template Error: Field type RapidClassification is not installed properly. Go to the list settings page to delete this field. RRS feed

  • Question

  • Hi,

    I'm trying to save a site as a template but I do get an error as:

    Microsoft.SharePoint.SPException: Field type RapidClassification is not installed properly. Go to the list settings page to delete this field.    
     at Microsoft.SharePoint.SPFieldCollection.CreateSPFieldFromSafeArray(Int32 index)    
     at Microsoft.SharePoint.SPFieldCollection.CreateSPField(Int32 ifld)    
     at Microsoft.SharePoint.SPFieldCollection.EnsureSPField(Int32 index)    
     at Microsoft.SharePoint.SPFieldCollection.ItemAtIndex(Int32 iIndex)    
     at Microsoft.SharePoint.SPSolutionExporter.ExportFields(SPFieldCollection fields, String partitionName)    
     at Microsoft.SharePoint.SPSolutionExporter.ExportLists()    
     at Microsoft.SharePoint.SPSolutionExporter.GenerateSolutionFiles()    
     at Microsoft.SharePoint.SPSolutionExporter.ExportWebAsSolution()    
     at Microsoft.SharePoint.SPSolutionExporter.ExportWebToGallery(SPWeb web, String solutionFileName, String title, String description, ExportMode exportMode, Boolean includeContent, String workflowTemplateName, String destinationListUrl)    
     at Microsoft.SharePoint.SPSolutionExporter.ExportWebToGallery(SPWeb web, String solutionFileName, String title, String description, ExportMode exportMode, Boolean includeContent)    
     at Microsoft.SharePoint.ApplicationPages.SaveAsTemplatePage.BtnSaveAsTemplate_Click(Object sender, EventArgs e)    
     at System.Web.UI.WebControls.Button.OnClick(EventArgs e)    
     at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument)    
     at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)    
     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    I still can't figure it out where does this field reside? As I've gone through all fldtypes_xxx.xml files under 14/TEMPLATE/XML Directory, still I didn't find this field type. Also this is not any custom field which I've deployed. This error was also seen when activating the "SharePoint Server Publishing Infrastructure" Feature.

    Any help on this would be highly appreciated!

    Best Regards,

    Vishwajit

    Monday, December 5, 2011 9:31 AM

Answers

  • I always hated seeing this error.  it stands to reason then that you've got some customised content or solutions in your farm?

    I'd check your Site Column Gallery to see if its there.  If it is, see if you can access and delete it.

    Failing that, you may need to delete it via PowerShell.


    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/
    Monday, December 5, 2011 3:08 PM
    Answerer