none
Linux VM backup fails with VSS error RRS feed

  • Question

  • Hi,

    I have a Linux VM hosted on a Hyper-V host and i get VSS error while taking Backup, Below the error:

    The VSS application writer or the VSS provider is in a bad state. Either it was already in a bad state or it entered a bad state during the current operation. (ID 30111 Details: VssError:The writer experienced a non-transient error.  If the backup process is retried,
    the error is likely to reoccur.
     (0x800423F4))

    Not sure what needs to be checked as I have few more Linux VMs who's backup is going good.

    Please advise.

    Regards,

    Pramodh.

    Wednesday, September 28, 2016 9:47 AM

All replies

  • We had the same problem with Ubuntu 16.04 VMs. We updated the server apt-get dist-upgrade and installed the VSS Daemon (Technet article) and rebooted the VM. After that it worked.
    Wednesday, October 19, 2016 11:34 AM
  • Hi,

    I disabled Backup (Volume Snapshot) Integration service on Linux VM and started DPM backup and it worked.

    As per my understanding after going through couple of Technet articles, Backup integration service will help in taking Live backup of a VM. As I have disabled it now it means VM goes to pause state until backup is completed

    I have few Linux/RHEL VMs whose backups are good without disabling Backup Integration Service.

    What should i do to take live backup of VM?

    Thursday, November 24, 2016 12:30 PM
  • See my previous comment.
    Friday, November 25, 2016 10:42 PM
  • Hi Christian,

    I was told by the Linux expert team that given suggestion cannot be applied/not feasible in our infra 

    Monday, November 28, 2016 9:35 AM
  • I hate to resurrect an old thread, but....

    I've been experiencing this same issue in our environment starting a month or two ago. Our Linux VM's are running CentOS 7. Following the update to kernel version kernel.x86_64 0:3.10.0-327.28.3.el7 we began having this issue when taking backups of these VM's with the Backup Services feature enabled on the VM. This issue persists after updating to kernel.x86_64 0:3.10.0-514.6.2.el7 this week. I don't track the versions closely enough to verify, but it seems to have coincided with the update to CentOS 7.3.

    I had tested manually installing LIS on one of these VM's, which corrected the issue. This isn't really a manageable solution, however, since it must be removed/reinstalled any time the kernel is updated (and this functionality is supposed to be included in the kernel anyway).

    For now I've disabled the Backup Services feature on these VM's, but having this functionality back is definitely a priority for us.

    We're experiencing this on both DPM 2012 R2 (current UR, running on Server 2012 R2) and DPM 2016 (UR2, running on Server 2016).

    Friday, February 24, 2017 6:29 PM