none
Remove stale records from DPMDB RRS feed

  • Question

  • In DPM 2010, I delete a protection group and the DPM server console crashed while it was deleting the group. I ran the script I found on: http://social.technet.microsoft.com/Forums/en-GB/dataprotectionmanager/thread/20f1550c-d860-4416-8a3b-fed34b5c893d to make sure the datasource deleted fully, but it looks like they did not. Is there some way for me to delete these stale records? One thing I tried was to just recreate the protection group, and it seemed to create fine, but I would consistently get a run consistency check error message for the child datasources. Additionally the get-protectiongroup does not show the stale record, but get-datasource will show the stale records and get-recoverypoint does not return any records as well.

    Thursday, March 17, 2011 3:47 PM

All replies

  • Anyone? Is there not a SQL script that I can run that would either A) Delete the orphaned rows or B) Tie a protection group to the orphaned datasources so that I could delete it through the GUI or a cmdlet?
    Friday, March 18, 2011 5:41 PM
  • The reason I am asking is due to the following error I get when trying to back up my primary DPM server from secondary dpm server:
    DPM is unable to enumerate contents in \\?\Volume{4f7c0754-f0ef-11df-9e89-00155d641501}\ on the protected computer primary dpm server. Recycle Bin, System Volume Information folder, non-NTFS volumes, DFS links, CDs, Quorum Disk (for cluster) and other removable media cannot be protected. (ID: 38)

    The volume \\?\Volume{4f7c0754-f0ef-11df-9e89-00155d641501}\ is a volume that is not located on this system, MOUNTVOL does not show it as a listed volume, the only place I can see this volume name is the DPMDB database. If anyone know of another way to resolve this, I would be grateful.

    Tuesday, March 29, 2011 5:37 PM