locked
App-V HTTP content stream and Proxy RRS feed

  • Question

  • Hi all,

    I use SCCM BITS enabled Distribution Points to deliver AppV package content to virtual clients. The clients are multihomed, meaning they have an internal NIC to connect to the internal virtual LAN connected to a hyper-v vswitch and an external NIC connecting them to the outside internet. However, for some reason, App-V always decides to use the external NIC and thus fails to find package content. If I disable the external NIC, the client becomes single homed and can find its content immediately. The Internal NIC is the primary NIC in Windows 7, yet it still wants to go to the external NIC first and gets caught by the external proxy (which gives a HTTP 404 error).

    I set the proxy using IE and provided the following command through the command line interface:
    netsh winhttp proxy proxy-server="PROXY" bypass-list="*.mydomain.lab"

    PROXY is a non-existent name, which I use to enable the bypass list.

    Even after a reboot, it STILL gets forced to go to the outside proxy server.

    If anybody has any ideas, I welcome them :)
    Regards


    Check out my blog sysmgmt.wordpress.com
    Thursday, February 17, 2011 2:07 PM

Answers

  • Altered streaming protocol for clients, now using CIFS, thus bypassing the proxy completely and it works like a charm.


    Check out my blog sysmgmt.wordpress.com
    Monday, February 21, 2011 2:35 PM

All replies

  • I'm assuming that the external adapter has a default gateway assigned while the internal adapter does not - in the adapter bindings (see Advanced Settings in the Network Connections folder) the internal network adapter should have the highest binding.
    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    Thursday, February 17, 2011 2:19 PM
    Moderator
  • Aaron,

    I double-checked to see whether my gateway were correct and as far as I know they are:

    External NIC = DHCP
    Internal NIC:

    IP: 10.0.0.11/24
    GW: 10.0.0.1 (=DC with integrated DNS)

    All records are accurate in DNS.

    The internal NIC also has highest priority.

    The file and printer sharing binding on the internal NIC is at pos1, then the microsoft network client. I cannot imagine these two having to be swapped?

    Thanks!


    Check out my blog sysmgmt.wordpress.com
    Thursday, February 17, 2011 2:29 PM
  • A little update:

    I managed to narrow it down to windows 7 routing. I added static routes to my distribution points, but still it tries to communicate over to the wrong NIC. I know by setting the nics metics I can force windows to use the internal NIC first, but this is a bit awkward:

    Setting the internal nic to a a metric of 2 (noticed local loopback adapter is 1, hence 2) and the ext. nic to 3, it doesn't do anything. Setting internal to 9999 it works. But then all my internet traffic is routed to the internal nic as well and internet doesn't work. Narrowing the difference somewhere results in switching back to: internet=yes; appv=no. I tried fine tuning, but this doesn't seem to be helping me, because at some point it will switch over to app=yes and internet=no. I don't think this will ever be solved. But does that mean App-V doesn't support multihomed clients?!

    Regards,
    Jeroen


    Check out my blog sysmgmt.wordpress.com
    Friday, February 18, 2011 12:48 PM
  • Could you not simply the configuration and use a gateway/firewall to bridge the networks, rather than have each client do it themselves?
    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.
    • Proposed as answer by znack Monday, February 21, 2011 6:42 AM
    • Unproposed as answer by Jeroen Erkelens Monday, February 21, 2011 2:35 PM
    Friday, February 18, 2011 1:21 PM
    Moderator
  • Aaron,

    Well I probably could but this is merely a small POC environment. I would like to keep it as small scaled and straight-forward as possible.
    I'll take your suggestion into consideration!

    Thanks,

    Jeroen


    Check out my blog sysmgmt.wordpress.com
    Friday, February 18, 2011 1:29 PM
  • Altered streaming protocol for clients, now using CIFS, thus bypassing the proxy completely and it works like a charm.


    Check out my blog sysmgmt.wordpress.com
    Monday, February 21, 2011 2:35 PM