none
Server Error in Application "DEFAULT WEB SITE/SMSREPORTING_SRO"

    Question

  • I'm trying to run my first report on a fresh install of SCCM 2007 R2 installed on Win2K8R2 64 bit.  After installing a reporting point, I right click any report and get the following error message: Server Error in Application "DEFAULT WEB SITE/SMSREPORTING_SRO".  BTW,I've confirmed that ASP is installed in IIS. 

    To troubleshoot this, I checked the IIS Authentication and found that although Anonymous Authentication was enabled for the default web site, it was not enabled in the SMSReporting_SRO site.  If I enabled Anonymous Authentication for this site, I get the error message below:

    An error has occured in the script on this page.

    Line: 901

    Char: 2

    Error: Object required: 'XMLReports'

    Code: 0

    URL: http://sccm1/SMSReporting_SRO/ReportsNAV.asp?ReportID=91&DashboardID=$ShowTree=False

    Any help on this would be much appreciated.  Thanks.

    Wednesday, July 7, 2010 4:08 PM

Answers

  • Does the Event Viewer show any errors?

    Is any proxy server in use or in the IE Properties?

    Have you tried using the IP Address or FQDN for  http://sccm1/SMSReporting_SRO/ReportsNAV.asp?ReportID=91&DashboardID=$ShowTree=False  ?

    Are install Basic and Windows authentication in IIS ?

    What accounts are in the Reporting users local Group?

    Is this failing when accessing it locally from the server?


    David Baur
    Tuesday, July 20, 2010 4:20 AM
  • Success!!!

     

    I didn't have Basic and Windows authentication installed in IIS.  Once that was changed, the reports run fine.

     

    BTW, there were no errors in the event logs, no proxy in IE, IP and FQDN didn't help either and it did fail when accessing it locally.

     

    Thanks so much to both of you for sticking with this and resolving this issue.  Now I can continue on deploying SCCM!

     

    -Jason

    • Marked as answer by circecat Tuesday, July 20, 2010 4:23 PM
    Tuesday, July 20, 2010 4:23 PM

All replies

  • Review the steps for "Prerequisites for Reporting" at http://technet.microsoft.com/en-us/library/bb681030.aspx as you need to manually enable Windows Authentication (http://technet.microsoft.com/en-us/library/cc431377.aspx) among other things. After going through these and verifying the settings then unisntall the Reporting Point, then Reboot and then try to add the Reporting Point again. let me know how it goes! 
    David Baur
    Wednesday, July 7, 2010 5:42 PM
  • I went through these two articles and actually had everything configured per the recommendations.  I did go ahead and delete the Reporting Point, reboot, and re-install the Report Point.  No dice.  Same error.

     

    -Jason

    Wednesday, July 7, 2010 6:25 PM
  • Some other thing to check then.

    • Is the User a member of the SMS Reporting Users Security Group? and Make sure to Add Rights using the Admin Console as well. Does that make a difference?
    • If that fails, are you able to go to the URL Successfully by using the IP Address?
    • Are there any Proxy Servers Configured in IE?

    David Baur
    Wednesday, July 7, 2010 11:22 PM
  • Hi Jason,

    Could  you please try the following steps:


    1. Log on to your SCCM site server by using an account that has administrative permissions.

    2. Click Start, click Run, type dcomcnfg , and then click OK.

    3. In the Component Services MMC snap-in, expand Component Services, expand Computers, right-click My Computer, and then click Properties.

    4. In the My Computer Properties dialog box, click the COM Security tab.

    5. Under Launch and Activation permissions, click Edit Limits.

    6. In the Launch Permission dialog box, make sure that the Everyone group has Remote Launch and Remote Activation permissions.

    7. In the Component Services MMC snap-in, expand My Computer, expand DCOM Config, right-click SMS_Reporting_Point, and then click Properties.

    8. In the SMS_Reporting_Point Properties dialog box, click the Security tab. Under Launch and Activation Permissions, select Customize, and then click Edit.

    9. In the Launch Permission dialog box, make sure that the SMS Reporting Users local group has following permissions:

    Local Launch
    Remote Launch
    Local Activation
    Remote Activation


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, July 9, 2010 8:23 AM
  • I've checked all of these permissions in dcomcnfg and they were set as specified.  I'm still getting the same error though.

    -Jason

    Friday, July 9, 2010 2:33 PM
  • Hi Jason,

    Please remove and re-add reporitng point to see whether it will be OK.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, July 12, 2010 9:00 AM
  • I did that, rebooted and still get the same error.

    -Jason

     

    Monday, July 12, 2010 3:27 PM
  • What does the Reporting Setup Log state? Any Errors?
    David Baur
    Monday, July 12, 2010 5:16 PM
  • Nothing that I could find.  I've pasted the contents below:

    ==========================================
    Initialize variables.
    IIS is installed.
    Start web services.
    Configuring Registry.
    Executing: ReportingInstall /s /m=C:\PROGRA~2\MICROS~1\bin\i386\rep.val
    ReportingInstall.exe  returned 0
    Finished
    ==========================================
    Initialize variables.
    Deinstallation beginning
    IIS is installed.
    Start web services.
    Configuring Registry.
    Executing: ReportingInstall /s /m=C:\PROGRA~2\MICROS~1\bin\i386\rep.val /deinstall
    ==========================================
    Initialize variables.
    Deinstallation beginning
    IIS is installed.
    Start web services.
    Configuring Registry.
    Executing: ReportingInstall /s /m=C:\PROGRA~2\MICROS~1\bin\i386\rep.val /deinstall
    ReportingInstall.exe  returned 0
    Removing Reporting Registry Key - No longer in use.
    Finished
    ==========================================
    Initialize variables.
    IIS is installed.
    Start web services.
    Configuring Registry.
    Executing: ReportingInstall /s /m=C:\PROGRA~2\MICROS~1\bin\i386\rep.val
    ReportingInstall.exe  returned 0
    Finished
    ==========================================
    Initialize variables.
    Deinstallation beginning
    IIS is installed.
    Start web services.
    Configuring Registry.
    Executing: ReportingInstall /s /m=C:\PROGRA~2\MICROS~1\bin\i386\rep.val /deinstall
    ReportingInstall.exe  returned 0
    Removing Reporting Registry Key - No longer in use.
    Finished
    ==========================================
    Initialize variables.
    IIS is installed.
    Start web services.
    Configuring Registry.
    Executing: ReportingInstall /s /m=C:\PROGRA~2\MICROS~1\bin\i386\rep.val
    ReportingInstall.exe  returned 0
    Finished
    ==========================================
    Initialize variables.
    Deinstallation beginning
    IIS is installed.
    Start web services.
    Configuring Registry.
    Executing: ReportingInstall /s /m=C:\PROGRA~2\MICROS~1\bin\i386\rep.val /deinstall
    ReportingInstall.exe  returned 0
    Removing Reporting Registry Key - No longer in use.
    Finished
    ==========================================
    Initialize variables.
    IIS is installed.
    Start web services.
    Configuring Registry.
    Executing: ReportingInstall /s /m=C:\PROGRA~2\MICROS~1\bin\i386\rep.val
    ReportingInstall.exe  returned 0
    Finished

    Monday, July 12, 2010 7:57 PM
  • Okay...You state that you did make sure the userid you are logged into also in the SMS Reporting Users local group? Did you also go through the security wizard and re-add the rights to your logon ID to all the reports as well? That error usually indicates a security problem, so either IIS is messed up or security is somehow messed up. Any IIS Security Policies or Group Policies hitting this server?

     


    David Baur
    Wednesday, July 14, 2010 1:34 AM
  • Just to make sure I understand you, I've gone through the Security Rights by right clicking on Security Rights and selecting Manage ConfigMgr Users.  I've assigned all rights possible to both my user account and the service account.  This was done previously and I've confirmed that the error is still occuring.

    -Jason

    Wednesday, July 14, 2010 7:19 PM
  • Yes. What about Group ploicies or IIS Lockdown settings anything there?

    Have you tried uninstalling the Web Reporting, and then reinstalling and telling it to use a Custom Website?


    David Baur
    Thursday, July 15, 2010 6:35 PM
  • No GPO's or IIS Lockdown settings are applied.

     

    How would I go about uninstalling the Web Reporting, and then reinstalling and telling it to use a Custom Website?

     

    -Jason

    Thursday, July 15, 2010 10:51 PM
  • Well that actually refers to the WSUS Web Site, it is recommended that when it is installed you select to use a Custom Web Site. As for Removing the Web Reporting, it is under Site SYstems\Severname\(List of roles).

    You would delete it from here and then after it ois completely removed, try re-adding it back and see if it corrects.


    David Baur
    Saturday, July 17, 2010 3:07 AM
  • I tried that too and still no luck.

     

    -Jason

    Monday, July 19, 2010 3:26 PM
  • Does the Event Viewer show any errors?

    Is any proxy server in use or in the IE Properties?

    Have you tried using the IP Address or FQDN for  http://sccm1/SMSReporting_SRO/ReportsNAV.asp?ReportID=91&DashboardID=$ShowTree=False  ?

    Are install Basic and Windows authentication in IIS ?

    What accounts are in the Reporting users local Group?

    Is this failing when accessing it locally from the server?


    David Baur
    Tuesday, July 20, 2010 4:20 AM
  • Success!!!

     

    I didn't have Basic and Windows authentication installed in IIS.  Once that was changed, the reports run fine.

     

    BTW, there were no errors in the event logs, no proxy in IE, IP and FQDN didn't help either and it did fail when accessing it locally.

     

    Thanks so much to both of you for sticking with this and resolving this issue.  Now I can continue on deploying SCCM!

     

    -Jason

    • Marked as answer by circecat Tuesday, July 20, 2010 4:23 PM
    Tuesday, July 20, 2010 4:23 PM
  • Great, Glad to hear that it worked!

    David Baur


    David Baur
    Tuesday, July 20, 2010 8:15 PM
  • Some other thing to check then.

    • Is the User a member of the SMS Reporting Users Security Group? and Make sure to Add Rights using the Admin Console as well. Does that make a difference?
    • If that fails, are you able to go to the URL Successfully by using the IP Address?
    • Are there any Proxy Servers Configured in IE?

    David Baur

    Thanks. It worked for me but after opening the reports it shows a blank page, I mean it shows till "Show tree User:Domain\Username" & then under that a blank page :( Trying to fix it.
    Monday, May 20, 2013 11:50 AM
  • Is this on the site server or remote to the site server?

    http://www.enhansoft.com/

    Tuesday, May 21, 2013 3:23 PM
    Moderator