locked
Windows 2012 DHCP failover - can't configure RRS feed

  • Question

  • I used the Export-Dhcpserver and Import-Dhcp server cmdlets to easily move my 2008 DHCP configuration to 2012. The 2012 server is working just fine in place of the 2008 server.

    I'm now trying to configure failover. None of the imported scopes let me do it - the option to configure failover is not there. If I create a new scope from scratch, the configure failover option is there.  Is there something about imported scopes that I have to change?

    Saturday, October 20, 2012 9:14 PM

Answers

  • Hi,

    One thing I found out is that if your scope is define to distribute address for both DHCP or Bootp, the configure Failover button won't appear.  Because I had also few scope that I was unable to configure and comparing them, I finally found out they were the only one set to both Bootp/DHCP.

    You see that from properties on the scope and then in the Advanced tab.

    -Sylvain

    • Marked as answer by Patrick Kremer Friday, November 23, 2012 4:36 PM
    Thursday, November 22, 2012 9:21 PM

All replies

  • Migrate split scope DHCP deployment to Windows Server 2012 DHCP Failover

    Before running this script in production environment, first try it on test server.

    Thanks

    • Proposed as answer by Mr XMVP Sunday, October 21, 2012 6:01 PM
    • Unproposed as answer by Patrick Kremer Tuesday, October 23, 2012 2:43 AM
    Sunday, October 21, 2012 2:34 PM
  • Hi,

    Thanks for your post.

    I cannot reproduce your issue in my test environment. Did you mean the configure failover option was not present? Have you tried at both server level and scope level? At single Scope level (Right click Scope Name -> Configure Failover…) or at Server level (Right click IPv4 -> Configure Failover…).

    Best Regards,

    Aiden

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Aiden Cao

    TechNet Community Support

    Tuesday, October 23, 2012 1:46 AM
  • Hello - I tried the script that was recommended above, but I get the same behavior.

    @Aiden - correct, I mean there is no failover option on any scope that I have imported. Configure failover should be between Advanced and Reconcile in the right-click context menu. It is not available for any of my imported scopes. If I try configuring failover at the server level, it does not list any of the imported scopes as being available for failover. Any new scope that I create is available for failover, but none of the imported ones. Is there some property of a scope that makes it ineligible for failover? The screen that comes up says "Scopes which are already configured for high availability are not displayed in the list below." Is it possible the import sets some kind of flag that I could unset?

    Tuesday, October 23, 2012 2:35 AM
  • Hi,

    Are there scopes migrate from Server 2003 or earlier version to Server 2008? Did you follow the below article the export the DHCP database from Server 2008? Please add -verbose parameter, to see if there any error after the export or import. If possible, you may perform this migration once again. I exactly follow the steps described in this article. And I cannot reproduce you issue.

    Migrating existing DHCP Server deployment to Windows Server 2012 DHCP Failover
    http://blogs.technet.com/b/teamdhcp/archive/2012/09/11/migrating-existing-dhcp-server-deployment-to-windows-server-2012-dhcp-failover.aspx

    Best Regards,
    Aiden

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Aiden Cao

    TechNet Community Support

    • Marked as answer by Aiden_Cao Thursday, November 1, 2012 2:01 AM
    • Unmarked as answer by Patrick Kremer Friday, November 23, 2012 4:36 PM
    Tuesday, October 23, 2012 7:38 AM
  • Hi,
     
    How are things going? I just want to check the status of the issue. If you have any update or concern, please feel free to let us know.

    Best Regards,
    Aiden

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Aiden Cao

    TechNet Community Support

    Wednesday, October 31, 2012 1:25 AM
  • I reran the whole import/export process from 2008 R2 to 2012.  Now, all of the scopes except for one have the failover option available. I don't really know what's wrong but I can recreate that one scope from scratch.

    • Marked as answer by Aiden_Cao Thursday, November 1, 2012 2:01 AM
    • Unmarked as answer by Patrick Kremer Friday, November 23, 2012 4:36 PM
    Wednesday, October 31, 2012 12:50 PM
  • Hi,

    One thing I found out is that if your scope is define to distribute address for both DHCP or Bootp, the configure Failover button won't appear.  Because I had also few scope that I was unable to configure and comparing them, I finally found out they were the only one set to both Bootp/DHCP.

    You see that from properties on the scope and then in the Advanced tab.

    -Sylvain

    • Marked as answer by Patrick Kremer Friday, November 23, 2012 4:36 PM
    Thursday, November 22, 2012 9:21 PM
  • Sylvain, thank you!!! You are absolutely correct, this was the problem!
    Friday, November 23, 2012 4:37 PM
  • Thank you! I had exactly the same problem note being able to set-up a symmetric topology. I couldn't find this in any documentation.
    Tuesday, October 22, 2013 10:18 AM
  • perfect answer, works fine now.
    Thursday, January 21, 2016 10:00 PM
  • Hi,Im trying to select the option bootp but it is giving an error as on server 2012 this option cannot be changed to bootp or both.Any suggestion?
    Tuesday, November 7, 2017 11:17 AM