locked
BI Dev RRS feed

  • Question

  • I have a "Business Unit" dimension which has a BusinessUnit (description) and BusinessUnitCode (numeric number of BU) as BusinessUnit Dimension attributes.  When I run a view (with totals) and include the BussinessUnitCode Attribute I get a correct total.   When I include or request only the BusinessUnit, I get wrong totals - detail info is good, the total is just wrong.  It doesnt make any difference what measure I use, the totals flop good to bad depending if BusinessUnit is included.   I have removed all heirarchies thinking this might be the problem, but it just runs slower but still get the wrong totals.

    The ProClarity anaysis totals says I am on hot fix 6.3.2217 and 6.3.2222

    Thanks for any help 

    dick_rider@msn.com

     


    dick rider
    Monday, September 20, 2010 2:08 AM

All replies

  • Dick,

    Here's a document that begins to describe a bit about how ProClarity works with totals.  http://blogs.technet.com/b/proclarity/archive/2008/08/06/updated-aggregation-in-proclarity-6-3-with-ssas-2005-sp2.aspx.  ProClarity uses the WITH MEMBER clause and AGGREGATE keyword to aggregate and create the total.  This doesn't always produce the desired result. 

    We see new cases of totaling issues every once in a while.  Are you running this against SSAS 2008 or later?  I'm curious to know what it is about BusinessUnit that is causing the totals to fail. 

    These can be pretty detailed problems that often require careful review of the design of the cube objects such as the BusinessUnit attribute.  However, it would be great it you could repro in Adventure Works and post that here.  If not, I'd have to see more detail about your issue or have you open a support case.

    Thanks,

    -Joey

    Thursday, September 23, 2010 10:31 PM