locked
DIAL-IN tab missing from RSAT package AD Users & Computers snap-in RRS feed

  • Question

  • The Active Directory Users & Computers snap-in that runs on Windows 7 as part of the RSAT package x86fre_GRMRSAT_MSU is missing the DIAL-IN tab on user accounts  that is present on the snap-in when run on a DC.

    Is there a reason for this?

    Cheers,
    Mark.
    Wednesday, September 30, 2009 12:03 AM

Answers

  • Hi Mark,

     

    Based on the research, on Windows 7 client, when we use Active Directory Users and Computers snap-in that is included in RSAT tool (x86fre_GRMRSAT_MSU) to connect to domain controller, the Dial-in tab is not there. We have confirmed that this is by design in the RSAT for Windows 7, and our product team has been aware of this.

     

    Currently, as a workaround, you may consider remote connect to the DC via RDP and then use the ADUC when you need to manage dial-up settings.

     

    If there is any update, we will let you know as soon as possible.

     

    Thanks for your understandings.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by David Shen Friday, October 2, 2009 2:07 AM
    • Marked as answer by David Shen Monday, October 5, 2009 3:19 AM
    Wednesday, September 30, 2009 5:32 AM

All replies

  • Hi Mark,

     

    Based on the research, on Windows 7 client, when we use Active Directory Users and Computers snap-in that is included in RSAT tool (x86fre_GRMRSAT_MSU) to connect to domain controller, the Dial-in tab is not there. We have confirmed that this is by design in the RSAT for Windows 7, and our product team has been aware of this.

     

    Currently, as a workaround, you may consider remote connect to the DC via RDP and then use the ADUC when you need to manage dial-up settings.

     

    If there is any update, we will let you know as soon as possible.

     

    Thanks for your understandings.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by David Shen Friday, October 2, 2009 2:07 AM
    • Marked as answer by David Shen Monday, October 5, 2009 3:19 AM
    Wednesday, September 30, 2009 5:32 AM
  • Another workaround is to copy/paste the required DLL's from a computer running Windows Server 2008 R2 into Windows 7.

    Copy these from Server 2008 R2:
    Windows\system32\mprsnap.dll
    Windows\system32\rasuser.dll
    Windows\system32\rtrfiltr.dll
    Windows\system32\en-US\mprsnap.dll.mui
    Windows\system32\en-US\rasuser.dll.mui
    Windows\system32\en-US\rtrfiltr.dll.mui


    Paste into cooresponding directories on Windows 7. 

    Run:
    regsvr32.exe Windows\system32\rasuser.dll

    • Proposed as answer by M. King Wednesday, February 17, 2010 4:42 PM
    Monday, October 12, 2009 4:57 PM
  • file copy above only works for 64bit clients, so 32bit W7 no joy.
    Wednesday, October 28, 2009 5:40 AM
  • file copy above only works for 64bit clients, so 32bit W7 no joy.

    Try this (I don't run 32-bit, or I would try it myself)...

    Copy these from Server 2008 R2 to 32-bit System32 and System32\en-US:
    Windows\SysWOW64\mprsnap.dll
    Windows\SysWOW64\rasuser.dll
    Windows\SysWOW64\rtrfiltr.dll
    Windows\SysWOW64\en-US\mprsnap.dll.mui
    Windows\SysWOW64\en-US\rasuser.dll.mui
    Windows\SysWOW64\en-US\rtrfiltr.dll.mui

    Run: regsvr32.exe Windows\system32\rasuser.dll
    • Proposed as answer by EduFon Wednesday, January 13, 2010 5:18 PM
    Tuesday, November 3, 2009 5:09 PM
  • This looked so promising, I copied the files OK and regitered the DLL, didn't get an error about mismatched platform DLL. Started ADUC but still no dialin tab either. There is a flash like something has loaded and crashed really quickly, otherwise the tabs look normal.
    Tuesday, November 3, 2009 10:37 PM
  • This procedure work great.  You only need run CMD with Administrator permission and then run "regsvr32.exe Windows\system32\rasuser.dll " .  If you don´t run, an 0x00 error appears...

    Sorry about my english.

    Eduardo.
    • Proposed as answer by EduFon Wednesday, January 13, 2010 5:18 PM
    Wednesday, January 13, 2010 4:21 PM
  • Reran the regsvr32 command with CMD windows started as Administrator to doubble check. registration works, but no dail-in tab in ADUC
    Thursday, January 14, 2010 4:41 AM
  • We currently have a 2003 domain. The admin and helpdesk team are having Windows 7 clients already. We had the same problem with the missing dail in tab.
    Because of 802.1x security and VPN dail-in this tab is important for us. I foudn this post and tried with files from a Windows Sever 2008 (32 / 64 bit) without success. With the 32 bit files I saw the tab but when I clicked it I got an error "could not load the dail-in profile for this user because: member not found .". Then I've tried to use the files from one of our Windows Server 2003. Now it works for us.

    I've copied these files:

    mprsnap.dll
    rasuser.dll
    rtrfiltr.dll

    and registered them using this command:

    regsvr32.exe %windir%\system32\rasuser.dll

    Maybe this is helpful for some of you too.


    Regards Thomas
    Tuesday, February 9, 2010 6:50 AM
  • Extract the files from the "Windows Server 2003 Service Pack 2 Administration Tools Pack for x86 editions" MSI . Worked for me (32bit Windows7 and 64Bit Windows 2008). 


    • Proposed as answer by M. King Wednesday, February 17, 2010 4:44 PM
    Wednesday, February 17, 2010 2:46 PM
  • Thanks mr.quickly and M.King!  This worked for me, although running regsrv32 on rtrfiltr.dll errored for me, the tab showed up in my Win7 32bit machine. 

    Thursday, February 25, 2010 7:21 PM