none
IE site restriction RRS feed

  • Question

  • I am not able to get the web site restrictions to work.  Under Feature Restrictions I have the prevent internet access box checked and only one site in the web addresses allowed.  When logged in as the restricted user I can surf the web at will.  How can I debug this?  Thank you.

     

    Friday, July 6, 2007 3:07 PM

Answers

  • Hello Steve,

     

    Based on my test, the non-standard port web site is same as the standard port web site. We only need to input the IP address in the permitted URLs box. After that, you can access the internal web site.

     

    For example, one internal web site http://192.168.16.2:9999, you only need to input the 192.168.16.2 in the permitted URLs box.

     

    Thanks and have a nice day!

    Thursday, July 19, 2007 10:53 AM

All replies


  • Since SteadyState sets the website access restriction via [Internet options->Connections->Local Area Network->Lan Settings], we can use the following steps to manually configure ie settings to see if it works.

    1.Logon as a administrator, create a new user in Steadystate and set no restriction(windows restriction and feature restriction) for the user.

    2.Logon as the new user, Open IE>tools menu>internet options>Connections>Lan Settings,
      a.  make sure "Automaticall detect settings" is unchecked

    b.  check box under "Proxy Server", in the address box, input an ip address that is not used in the environment;

    c.  click Advanced>under Exceptions box,input *.msn.com

    3.Logon as the new created user and test out. The user should only be allowed to access  websites like *.msn.com.

    Note: make sure "Automaticall detect settings" should be unchecked whether through manual configuration or SteadyState.

    If prolem persists,please export the related IE registry keys for the restricted user and send to me via emai: v-samyu@online.microsoft.com(no online)


    How to export the related registry keys:

    1.Logon as the restricted user(make sure the user has admin rights temporarily by add the user into the administrators group),
    click Start->Run->input regedit to open Registry Editor.

    2.Navigate to HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,right click File menu->Export... to save it as a reg file.


    By the way, you can refer to this thread on a similar issue.
    IE fine tuning? http://forums.microsoft.com/WindowsToolsandUtilities/ShowPost.aspx?PostID=1806532&SiteID=69

    Monday, July 9, 2007 8:27 AM
  • Hi -

    First, SteadyState was a quick and easy install and is doing 95% of what I want it to perfectly with no fuss - I'm impressed.

    In general, the URL restrictions are working properly for me.  However, I cannot for the life of me work out how to permit access to an internal site on a non-standard port: http://xxx.xxx.xxx.xxx:9999

    I used quotes to add the site to the permitted URLs, but I still can't access it in the restricted user profile.

    When I unlock the profile, I can browse to the site without issue.

    May I ask for some advice or assistance?
    Tuesday, July 17, 2007 3:07 PM
  • Any thoughts on why I'm having trouble with an internal site on a custom port?

    /bump post/
    Wednesday, July 18, 2007 3:04 PM
  • Hello Steve,

     

    Based on my test, the non-standard port web site is same as the standard port web site. We only need to input the IP address in the permitted URLs box. After that, you can access the internal web site.

     

    For example, one internal web site http://192.168.16.2:9999, you only need to input the 192.168.16.2 in the permitted URLs box.

     

    Thanks and have a nice day!

    Thursday, July 19, 2007 10:53 AM