locked
Exchange 2010 move request failed with MapiExceptionCallFailed RRS feed

  • Question

  • hi

    Attempting a local move request of Mailbox but it fails.

    plz help

    Request 'xxxxxxx' (c307df02-04f8-4428-855e-40cfd89fa67f) failed.error code: -2147467259
    MapiExceptionCallFailed: IExchangeFastTransferEx.TransferBuffer failed (hr=0x80004005, ec=1162)
    Diagnostic context:
        Lid: 55847   EMSMDBPOOL.EcPoolSessionDoRpc called [length=2082]
        Lid: 43559   EMSMDBPOOL.EcPoolSessionDoRpc returned [ec=0x0][length=689][latency=0]
        Lid: 23226   --- ROP Parse Start ---
        Lid: 27962   ROP: ropFXDstCopyConfig [83]
        Lid: 27962   ROP: ropTellVersion [134]
        Lid: 27962   ROP: ropFXDstPutBufferEx [157]
        Lid: 17082   ROP Error: 0x48A    
        Lid: 31329 
        Lid: 21921   StoreEc: 0x48A    
        Lid: 27962   ROP: ropExtendedError [250]
        Lid: 1494    ---- Remote Context Beg ----
        Lid: 1238    Remote Context Overflow
        Lid: 1947    StoreEc: 0x48A    
        Lid: 1435    StoreEc: 0x48A    
        Lid: 1947    StoreEc: 0x48A    
        Lid: 1435    StoreEc: 0x48A    
        Lid: 1947    StoreEc: 0x48A    
        Lid: 4559    StoreEc: 0x48A    
        Lid: 21802 
        Lid: 19994   StoreEc: 0x48A    
        Lid: 20202 
        Lid: 3305    StoreEc: 0x48A    
        Lid: 32762   dwParam: 0x3FE70003
        Lid: 32762   dwParam: 0x361384B0
        Lid: 32762   dwParam: 0x36170003
        Lid: 32762   dwParam: 0x36DA0102
        Lid: 32762   dwParam: 0x36E00102
        Lid: 32762   dwParam: 0x3FD60040
        Lid: 32762   dwParam: 0x3FE4000B
        Lid: 32762   dwParam: 0x67590102
        Lid: 32762   dwParam: 0x675A0102
        Lid: 32762   dwParam: 0x30080040
        Lid: 32762   dwParam: 0x675C0102
        Lid: 32762   dwParam: 0x65E30102
        Lid: 32762   dwParam: 0x67510003
        Lid: 32762   dwParam: 0x672D0003
        Lid: 32762   dwParam: 0x673384B0
        Lid: 32762   dwParam: 0x673284B0
        Lid: 26346 
        Lid: 4073    StoreEc: 0x48A    
        Lid: 28570   StoreEc: 0x48A    
        Lid: 29738 
        Lid: 3401    StoreEc: 0x48A    
        Lid: 1750    ---- Remote Context End ----
        Lid: 26849 
        Lid: 21817   ROP Failure: 0x48A    
        Lid: 22630 
    Context:
    --------
    Operation: IMapiFxProxy.ProcessRequest
    OpCode: TransferBuffer
    DataLength: 2362
    --------
    Operation: IMapiFxProxy.ProcessRequest
    OperationSide: Target
    Primary(c307df02-04f8-4428-855e-40cfd89fa67f)
    OpCode: TransferBuffer
    DataLength: 2362

     Any ideas?  any help much appreciated

    Wednesday, November 28, 2012 5:55 AM

Answers

All replies

  • Some possibilities:

    One - where are you moving this mailbox from?  A remote workstation that has the Exchange Management Tools installed or on an Exchange Server itself?  If its a remove workstation, make sure that your tools are the same version as your servers (match service pack and rollup up date).  

    Two - is this move from Exchange 2010 database to Exchange 2010 database or something like Exchange 2003 to Exchange 2010?  If it is 2003 to 2010, then consider moving the user to another database in 2003 and then move the user to 2010.

    Three - make sure the destiantion mailbox database does not have mailbox size restrictions that are smaller than the mailbox you are moving.

    Lastly - As a last resort you could export the mailbox to a PST, remove mail attirbutes, recreate the mailbox on another store and then restore the mailbox from the PST file you created.


    JAUCG


    Wednesday, November 28, 2012 3:06 PM
  • hi JAUCG

    thx for your reply

    One - another database on the same MBX server  ("mailboxdatabase 1" to "mailboxdatabase 2")

    Two - Exchange 2010 same version

    Three  - unlimited...

    help..

    Thursday, November 29, 2012 2:35 AM
  • What version of Exchange 2010?  SP2, RU #?   I saw this support article form MS for 2003 --> 2010 http://support.microsoft.com/kb/2579051.  Not sure if it is applicable.  It could be you need to go to RU4 for SP2 Exchange 2010.  Do not install RU5 as there were issues.

    I've also run into several support articles about ACLs on the mailbox or fiolders:

    http://runebelune.blogspot.com/2010/11/mapiexceptionnosupport.html [remember that Exchange 2010 you need to use ExFolders and not PFDAVAdmin]

    http://social.technet.microsoft.com/Forums/hi-IN/exchangesvrdeploylegacy/thread/73a385d5-ea2f-47b9-87f0-c481b1f29b35

    Let me know if I can provide any additional help.


    JAUCG

    Thursday, November 29, 2012 3:51 AM
  • I have 2 MBX and 2 CAS/HT

    all version Exchange 2010 SP2 RU4

    Thursday, November 29, 2012 5:32 AM
  • Based on my experience, the issue can be caused by incorrect command switch. So could you please post the cmdlet you were using to move the mailbox?

    Thansk.


    Fiona Liao
    TechNet Community Support

    Thursday, November 29, 2012 5:40 AM
    Moderator
  • hi~ Fiona_Liao

    New-MoveRequest -Identity xxx@xxxx.xxx-TargetDatabase "MBX-L501"

    thanks

    Thursday, November 29, 2012 6:51 AM
  • I assume you've tried the GUI with the same results, correct?  Have you checked the ACL articles?

    JAUCG

    Thursday, November 29, 2012 12:26 PM
  • yes. GUI same result

    ACL checked... not problem

     
    Friday, November 30, 2012 1:47 AM
  • Normally I would say run an isinteg against the database.  However with the release of SP1 for Exchange 2010 there is a new command you can run - 'New-MailboxRepairRequest -Mailbox <MailboxIdParameter>'  see here for information on the command - http://blogs.technet.com/b/exchange/archive/2010/08/23/3410708.aspx.  I would suggest a run against your mailbox that you are moving first.  If that does not work, then try it against the entire database.

    See here as well - http://eightwone.com/2010/06/14/goodbye-isinteg-hello-new-mailboxrepairrequest/

    Let us know if that helps.


    JAUCG

    Friday, November 30, 2012 3:10 AM
  • After a period of time, the problem was solved...

    thanks

    Tuesday, December 4, 2012 6:14 AM
  • I saw from the the log for our failed mailbox move request that the mailbox in question had over 2,800 folders in it.  This seemed high.  There was also a litigation hold on the mailbox, and I've seen a mailbox grow to *1TB* in size because of a litigation hold.  I opened the mailbox in Outlook and saw that there were tons of nested Junk E-mail folders.  I deleted them and the mailbox move completed successfully.

    http://blog.smu.edu/wis/2014/01/29/exchange-2010-mailbox-move-fails-with-mapiexceptioncallfailed/

    Wednesday, January 29, 2014 8:51 PM