locked
Auto-Attendant: "Sorry, I couldn't transfer you to the extension" RRS feed

  • Question

  • Hi, everyone!

    We're on Exchange 2010 and Lync 2013 Enterprise. All of the sudden after someone enters an extension or says a name, AA sits there silently for a moment and then eventually says "Sorry, I couldn't transfer you to the extension."

    I can't find anything in the logs on the Exchange server.

    It was working, but now it's not.

    I've seen multiple articles, but most don't seem to be the same problem. I did try adding a catch all Dial Policy as suggested here (http://blog.ucmadeeasy.com/2010/08/29/exchange-um-auto-attendant-key-mappings-not-transferring-calls-after-sp1/) to the Dial Plan and AA, but still no luck.

    Can someone please help?

    Thanks!

    -Eric

    Thursday, November 14, 2013 4:01 AM

All replies

  • Hi Eric,

    You can try the below steps

     Start s4,sipstack,mediation server and inbound routing component trace in lync server logging and see if any errors reported in logs and if it can help us

    Check if the translation rules were in the site dial plan instead of global dial plan
    If not then Create a translation rule within the global dial plan for the #8 key map
    Check with UM dial plan FQDN as and ensure its simple name in Global dial plan of lync
    create normalization rule in global dial plan to translate 3 digit no. to tel uri configured on RGS

    Check trunk config on FE/mediation (co-located)
    Also you can try the below settings
    "enable media bypass" is unchecked
    "enable refer support" is checked

    Thursday, November 14, 2013 4:44 AM
  • Sathish:

    Thanks! I'll try these things out tomorrow when I get back to work.

    I think I can run those tests easily and can check the translation rules are in the global plan as well as the site plan. (I think this may be the issue, but I'll confirm.)

    I'm not sure where in Lync CP I'd look for the Exchange UM FQDN. Could you maybe point me to the correct place you were referring to?

    I know the normalization rules are correct because you can dial a 3 digit extension and it translates properly. I'll double check the trunk config, but what's weird is that my Response Group passes the call off to the AA properly using its sip address, but the AA can't pass it back when a user is specified.

    Where are the "enable media bypass" and "enable refer support" located?

    Thanks again!

    -Eric
    • Edited by imeric82 Thursday, November 14, 2013 4:55 AM
    Thursday, November 14, 2013 4:53 AM
  • Sathish:

    I ran OCSLogger for those things, but I don't see anything specific. I'm not really sure what I'm looking for either.

    I also checked our translation rules. Everything was already set to Global, except the Trunk Configuration, so I added setting to the Global Trunk configuration.

    I'm still not sure where you want me to look to make sure the UM Dial Plan FQDN is setup in Lync. I've run the OcsUmUtil and it's all in there.

    Finally, we do have "Enable Media Bypass" checked, but that was "highly recommended to reduce processing in the Mediation Server." We also have "Centralized media processing" and "Enable outbound routing failover timer" checked.

    "Enable Refer Support" is set to "Enable sending refer to the gateway."

    I committed all the changes and waited about an hour to try calling again, but I'm still being told that AA is unable to transfer the call.

    Thursday, November 14, 2013 3:47 PM
  • I wonder if I've stumbled onto the problem. In Exchange, when I look at the Properties for the UM IP Gateway, the FQDN in there is pointing to the Lync Server, not the PBX Gateway. Shouldn't it be pointing to the Gateway?
    Thursday, November 14, 2013 4:07 PM