locked
Deleting an uninstalled program in the Program Files folder RRS feed

  • Question

  • i recently uninstalled Warhammer Online, but the war folder is still in my program files folder and i cannot delete it. i'm the owner of it and all that jazz but i can't get rid of it and it's taking up 9gigs of space that i can't use anymore. can anyone help? oh, warhammer also no longer appears in my control panel list of applications either. i hit delete, it asks for confirmation, i hit confirm, then it asks for my permission to continue, i click it, then it says "destination folder access denied" and "you need permission to perform this action" and my options are "try again" and "cancel" and try again does nothing. it's really frustrating because this one folder is 5% of my harddrive. any help would be appreciated.
    Thursday, October 9, 2008 10:57 PM

Answers

  • Curtis

     

    The following command will grant full access rights and full permissions to the target folder/files as well as all of it's sub-folders and files

     

    Log on with an administrator account.

    Go to Start / All Programs / Accessories.

    Right click the Command Prompt item and select the 'Run As Administrator' option.

    Click Continue on the UAC prompt.

     

    In the command window, enter the following command.

     

     icacls path /T /grant username:F

     

    Press ENTER.

     

    *Where 'path' is the path to the target folder or file.
    *Where username is the name of the administrator account you are currently logged on with.
    **Make sure the command is entered exactly as shown, including the spaces and colon.
    **If the 'path' contains any spaces, you will need to enclose the path in quotes.


    Example:  If the path to the target folder is C:\Program Files\Warhammer and your account name is Curtis.

    The command would look like this:

     

    icacls "C:\Program Files\Warhammer" /T /grant Curtis:F

     

    After you enter this command and press Enter, you should see a list of all the folders and files in the Warhammer folder scroll on the screen.

     

    Once this scrolling is complete, type this command.

     

    del "C:\Program Files\Warhammer"

     

    Press Enter.

     

    Post back if you need more help with this.

     


    If this post helps to resolve your issue, click the Mark as Answer button at the top of this message.

    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Friday, October 10, 2008 5:11 PM
    Moderator

All replies

  • you can try restarting the machine once and see. Also in vista, you can try by right clicking and selecting "Run As Administrator" and then try to delete file
    Friday, October 10, 2008 6:11 AM
  • Curtis

     

    The following command will grant full access rights and full permissions to the target folder/files as well as all of it's sub-folders and files

     

    Log on with an administrator account.

    Go to Start / All Programs / Accessories.

    Right click the Command Prompt item and select the 'Run As Administrator' option.

    Click Continue on the UAC prompt.

     

    In the command window, enter the following command.

     

     icacls path /T /grant username:F

     

    Press ENTER.

     

    *Where 'path' is the path to the target folder or file.
    *Where username is the name of the administrator account you are currently logged on with.
    **Make sure the command is entered exactly as shown, including the spaces and colon.
    **If the 'path' contains any spaces, you will need to enclose the path in quotes.


    Example:  If the path to the target folder is C:\Program Files\Warhammer and your account name is Curtis.

    The command would look like this:

     

    icacls "C:\Program Files\Warhammer" /T /grant Curtis:F

     

    After you enter this command and press Enter, you should see a list of all the folders and files in the Warhammer folder scroll on the screen.

     

    Once this scrolling is complete, type this command.

     

    del "C:\Program Files\Warhammer"

     

    Press Enter.

     

    Post back if you need more help with this.

     


    If this post helps to resolve your issue, click the Mark as Answer button at the top of this message.

    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Friday, October 10, 2008 5:11 PM
    Moderator
  • i have quite a lt of problems with that like ie8, i cant seem to get rid of it so could you tell me the command prompt code for it please cos i have no idea what to do about it

    Friday, October 10, 2008 6:03 PM
  • Dear Ronnie MVP,

     

    Had the same issue with Windows SQL Server 2005 files left behind in the program files folder of the C: however, when I would type the command you specified:

     

     icacls "C:\Program Files\Microsoft SQL Server" /T /grant SysAdmin:F

     

    I would get an - Invalid parameter "SysAdmin:F" error.

     

    Tried some other combinations of the command to no avail.  Any ideas on how to get to the list of the files and all the folders n the Microsoft SQL Server folder and get them to scroll on the screen?  Running Vista Business OS....

     

     

    Sincerely,

     

    Richard Hood

    Wednesday, November 12, 2008 12:54 PM
  • Is the username is SysAdmin

    please do confirm it is may be for oracle login

    Monday, December 17, 2012 1:43 PM