Remote Desktop Enable in Settings Switches Itself Off RRS feed

  • Question

  • Under what circumstances will the following happen:  Press the Windows key.  Click the gear icon for Settings.  Click System.  Click Remote Desktop.  There you will see a control.  Immediately above the control are these words:  Enable Remote Desktop.  Should you switch the control from Deny to Grant your request will be confirmed by a dialog box.  On my brand new ASUS computer running Windows 10 Pro I can confirm that the control on its own initiative switches from Grant to Deny.  Any idea why?


    Wednesday, May 30, 2018 8:33 PM

All replies

  • Hi!

    That's indeed very odd. When you click on the switch to enable the Remote Desktop, it will create a new self signed certificate to be used for the RD Session Host Server authentication and store it on your Local Certificates (in the Remote Desktop\Certificates store).

    Can you see in the System event log (in Event Viewer) if it was created? Look for Event ID 1056.

    Have you also tried enabling it from the other way?

    1) Go to Start and search for "Allow remote"

    2) Open the Allow remote access to your computer

    Best regards,

    Blog:  LinkedIn:   

    Wednesday, May 30, 2018 8:53 PM
  • I can see the 1056.  Also two 1036s: RD Session Host Server session creation failed. The relevant status code was Only one usage of each socket address (protocol/network address/port) is normally permitted.  Whatever that  is  meant to convey.  Do you think my one and only application covets port 3389?


    Wednesday, May 30, 2018 10:09 PM
  • The two ways to Enable Remote Desktop change in tandem.  I've only tried the new way to change state.  But I checked the other way and the radio buttons toggle along with the iPhone-type switch control under Settings. 

    Here is a better view of the 1056:


    Wednesday, May 30, 2018 10:17 PM
  • You could check your port 3389 how it looks like with the methods below:

    • Either use the following command: telnet <your IP address> 3389
    • Or use the following command: netstat -a and locate "TCP:3389"

    Blog:  LinkedIn:   

    Wednesday, May 30, 2018 10:27 PM
  • netstat -a reports there is nothing listening on port 3389 when Remote Desktop is Denied.  If you turn Remote Desktop on, however, there is something listening on port 3389.  I doubt the application (one and only) is interfering with Windows.


    Wednesday, May 30, 2018 10:46 PM