locked
Can't remove almost a full page of space between two sections of my document RRS feed

  • Question

  • Nothing I have tried will remove the 3/4 of a page of blank space between these two sections.  Please provide detail instructions as I did not even know Word had some of the formatting marks.

    Thank you very much for your help


    Will Weatherford

    

    Tuesday, April 19, 2016 2:26 AM

Answers

  • Stefan, you definitely sent me to the place in word that enabled me to fix it, but I needed to take a few slightly different steps.  They were:

    -Click in the table that has the blank space between two rows.
    -A yellow Table Tools label should appear over Design and Layout menus.
    -Select Layout then Propereties in the Table section
    -Table Properties window appears.  Select Row tab.  Use the Previous Row or Next row to navigate to the row that needs to be effected.
    -click OK
    -Home Menu > Paragraph Section > click icon in lower right to open the Paragraph Window.  
    -On Line and Page Breaks check Keep With Next checkbox to keep the next table row with the current table row.

    -Use the first steps above to navigate to the rows that need to be modified and the later steps to set "Keep With Next" and this will remove the blank space between rows.

     
    Thursday, April 21, 2016 8:30 PM

All replies

  • Hi BigRedWeather,

    this is forum related to developing. your issue is not related with developing. so that I move this thread to word it pro discussions forum. so that you can get more better response to solve your issue.

    Regards

    Deepak


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, April 19, 2016 6:19 AM
  • Your screenshots show content in a Word table - the '¤'symbols indicate a table's end-of-cell or end-of-row marker. In all likelihood, your table is formatted with the row staring on the second page formatted with the 'Allow row to break across pages' attribute unchecked. See under Table Tools>Layout>Properties>Row.

    Cheers
    Paul Edstein
    [MS MVP - Word]

    • Proposed as answer by Charles Kenyon Tuesday, April 19, 2016 12:31 PM
    Tuesday, April 19, 2016 9:44 AM
  • I expect that Paul's response is your answer. For further elucidation on formatting see:


    Charles Kenyon Madison, WI

    Tuesday, April 19, 2016 12:30 PM
  • Actually: "Allow row to break across pages" was checked.  I have tried selecting and deselecting that setting for the different rows of my table and I still can't remove the empty page between the two rows.  I have uploaded my whole file so you can work directly on the document that is giving me problems.  Trying to do this via many emails or postings would be an exercise in frustration.  WELL I TRIED TO ATTACH MY WORD DOCUMENT but I don't see a way to do that.  I will keep trying after I submit this update.

    I am not committed to this way of getting the look this document displays.  I would be happy to get the same appearance of columns, left and right, a different way if you have one to suggest.

    Thank you for your help thus far and that to come,

    BigRedWeather

    Wednesday, April 20, 2016 5:14 PM
  • How do I add an attachment to a posting?  It should be right under my nose, but I don't see it.
    Wednesday, April 20, 2016 5:24 PM
  • Update the file to OneDrive or Dropbox, make it public and post a link in this thread.


    Stefan Blom, Microsoft Word MVP

    Wednesday, April 20, 2016 5:34 PM
  • I am sharing this document because, despite suggestions from the good people on this forum, I am unable to remove about 3/4 of a page of blank space between two rows of the table.  I have tried the suggestions listed above.  If you could remove the blank space and tell me how you did it, it would be a great help.

    https://onedrive.live.com/redir?resid=AB9128F943B17416!110&authkey=!AApHoePcsZQfAMA&ithint=file%2cdocx

    Thank you,

    BigRedWeather

    Thursday, April 21, 2016 4:18 PM
  • I am sharing this document because, despite suggestions from the good people on this forum, I am unable to remove about 3/4 of a page of blank space between two rows of the table.  I have tried the suggestions listed above.  If you could remove the blank space and tell me how you did it, it would be a great help.

    https://onedrive.live.com/redir?resid=AB9128F943B17416!110&authkey=!AApHoePcsZQfAMA&ithint=file%2cdocx

    Thank you,

    BigRedWeather

         

    For each table row, turn off "Page break before" and "Keep with next" (in the Paragraph dialog box) and enable the option to allow the row to break across pages (on the Row tab of the Table Properties dialog box).

    To do this quickly, run the following simple macro:

    Sub FixTableFormattingMacro()
    'Created by Stefan Blom, MVP, April 2016
    Dim t As Table, r As Row
    
    For Each t In ActiveDocument.Tables
    For Each r In t.Rows
    r.AllowBreakAcrossPages = True
    r.Range.ParagraphFormat.KeepTogether = False
    r.Range.ParagraphFormat.PageBreakBefore = False
    r.Range.ParagraphFormat.KeepWithNext = False
    Next r
    Next t
    End Sub


    Stefan Blom, Microsoft Word MVP

    Thursday, April 21, 2016 6:37 PM
  • Stefan, you definitely sent me to the place in word that enabled me to fix it, but I needed to take a few slightly different steps.  They were:

    -Click in the table that has the blank space between two rows.
    -A yellow Table Tools label should appear over Design and Layout menus.
    -Select Layout then Propereties in the Table section
    -Table Properties window appears.  Select Row tab.  Use the Previous Row or Next row to navigate to the row that needs to be effected.
    -click OK
    -Home Menu > Paragraph Section > click icon in lower right to open the Paragraph Window.  
    -On Line and Page Breaks check Keep With Next checkbox to keep the next table row with the current table row.

    -Use the first steps above to navigate to the rows that need to be modified and the later steps to set "Keep With Next" and this will remove the blank space between rows.

     
    Thursday, April 21, 2016 8:30 PM
  • Note that in your example document, the big problem was that "Allow row to break across pages" was cleared (on the Row tab of the Table Properties dialog box). Selecting the option made all the difference, especially for the second row of the (long) first table in the document.

    Often it is a good idea to clear these various options (using a macro, for example) and then work through the document and reselect options as desired.

    In addition, displaying table gridlines in Word is very helpful.


    Stefan Blom, Microsoft Word MVP

    Thursday, April 21, 2016 9:46 PM
  • Stefan, you definitely sent me to the place in word that enabled me to fix it, but I needed to take a few slightly different steps.  They were:

    -Click in the table that has the blank space between two rows.
    -A yellow Table Tools label should appear over Design and Layout menus.
    -Select Layout then Propereties in the Table section
    -Table Properties window appears.  Select Row tab.  Use the Previous Row or Next row to navigate to the row that needs to be effected.
    -click OK
    -Home Menu > Paragraph Section > click icon in lower right to open the Paragraph Window.  
    -On Line and Page Breaks check Keep With Next checkbox to keep the next table row with the current table row.

    -Use the first steps above to navigate to the rows that need to be modified and the later steps to set "Keep With Next" and this will remove the blank space between rows.

    Thank you for sharing these detailed steps, it will be very beneficial for other community members.

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Monday, April 25, 2016 9:44 AM