none
ILR not working correctly on DPM 2012 R2 RRS feed

  • Question

  • Hi I am running a virtual DPM server version 2012 R2 UR9

    The only workloads I backup are hyper-v workloads. A key feature which I depend on is the Item Level Recovery. This is because the majority of workloads I backup and need to restore are small files inside large volumes. Without ILR it would take a long time to restore the vhdx just to get a small file back.

    I am having an issue where the ILR feature simply stops working randomly for a virtual machine. I get DPM error codes 958 and 0x80990F4E

    What is strange is I can go back to an earlier recovery point and browse the vhdx with ILR. For instance a VM I am currently protecting I can browse with ILR all recovery points from Monday 22nd of February and earlier. All recovery points after this date cannot open with ILR and I get the before mentioned error.

    I have checked the virtual machines which encounter this problem and there are no changes to their volume type, they are all just simple volumes formatted with NTFS.

    Is there a solution to this issue? It is a real risk not being able to recovery items in a timely fashion.

    Thursday, March 3, 2016 11:02 AM

All replies

  • I did a test on the aformentioned VM which was exhibiting this behaviour.

    Running a consistency check on the virtual machine after the virtual machine was rebooted allows me to browse the subsequently created recovery points. I did this last night.

    However all the recovery points between 23rd of February and last night are still not browsable using ILR.

    If I recover the whole VHDX for one of the problematic recovery points I am able to mount it fine afterwards so the recovery point is not corrupt.

    Thursday, March 3, 2016 8:56 PM
  • Same problem here...
    Tuesday, March 8, 2016 4:11 PM
  • Interesting...I'll have to try this and get back to you. I am getting the same error code 958 and 0x80990F4E when I try to do a ILR on some Windows Server 2008 R2 VM's using a DPM 2012 R2 VM....but this is not consistent across the board. In other words I am able to do a ILR on some VM's but not others but I can't seem to pinpoint why. I saw some other theories that stated you could not have an attached ISO/dvd drive to the VM in hyper-v manager (Hypervisors are 2012 R2) but I tested that out and it doesn't seem to have any effect. I am aware of the workaround to restore the entire .vhdx and then mount it but DPM should be able to do ILR for the rest of the VMs. If I could only find the difference between the ones that work with ILR and the ones that don't I think It would solve everyones problem!
    Thursday, March 24, 2016 11:05 PM
  • Did you ever get to the bottom of this?

    Its a massive coincidence that I am having the same issues which seemed to have started around the same time.

    I've removed all the DVD drives too but cant see a reason, some are generation 1, some are 2 not have dynamic drives in them.. its weird.

    Tuesday, May 10, 2016 2:01 PM