locked
Process Hang RRS feed

  • Question

  • Hi,

    recently i have removed local admin rights from some users. Now 3-4 users of them are not able to login into CRM application. once they enter user name / password, screen hang. Seems to be some rights issue. if i will add those users into local admin group, CRM Application works fine. but strange thing is rest other users are able to access this CRM application without local admin rights. i have tried to check it thorough ProcessMon / WinDBG. created process dump with procdump & trying to read it with WinDBG & not getting what to check. tried to uninstall/reinstall this CRM software / tried to delete this user local profile & recreate it but same results. Kindly let me know how to debug it.

    Dhiraj 

    Friday, March 4, 2011 10:39 AM

All replies

  • If I were you I would try the following procedure on a Windows where CRM hasn't been installed before:

    • Create a restore point in the System Restore.
    • Install the CRM application.
    • Create a restore point.
    • Log on as a normal user (without local admin rights).
    • Set the monitoring of the CRM application (through Process Monitor etc.) and start it. The application will hand at login and the monitoring logs will contain the details on possible causes of the problem (failed read/writes to the Registry or files).
    • Log on as a user with local admin rights.
    • Set the monitoring of the CRM application as before and start it. The monitoring logs will contain the details on successful application start and login process.
    • Compare two sets of the monitoring logs to find out the differences.
    • You can revert to the created restore point if you want to repeat the monitoring.

    Hope this helps.

    -- rpr.

    Monday, March 7, 2011 2:39 PM
  • Hi rpr,

    Thanks for your suggestions. i have taken both Procmon logs, saved in csv format & then tried to compare both but not getting any "Access Denied". Facing same kind of problem on another system which is running without local admin rights & unable to access another application. application hangs but when he is logging with local admin rights, able to acess both appllication. in Procmon logs i have tried to filter logs only related to that process (Exe), but not getting the cause of the problem.

    Dhiraj

    Wednesday, March 9, 2011 12:45 PM