none
WDS, DHCP and WSUS on same server, Virtuals find WDS and start up process, Physicals get PXE-X55 error. RRS feed

  • Question

  • I have a Windows 2012 R2 server that has the WSUS, WDS and DHCP roles installed. I also have a SCVMM (Win2012R2) server on different machine and it has been connected to the WDS server

    Followed many different guides on the internet to configure the WDS server but if I have option 60 configured the virtual machines will find and do a PXE boot successfully, but the physical systems will fail with a E55 error.

    I take out option 60 and both fail.

    Did I miss a niggly bit some where?


    Tuesday, February 17, 2015 4:08 PM

Answers

  • Have you tried this (from article):

    Custom-made Option 60 – String – PXEClient
    Predefined Option 66 – IP or Hostname of the WDS Server (in our case 10.150.150.1)
    Predefined Option 67 – boot\x86\wdsnbp.com

    and this in WDS properties:

    and

    Many people remark this as solution:

    WDSUTIL /Delete-AutoAddDevices /DeviceType:ApprovedDevices


    • Edited by fapw Wednesday, February 18, 2015 2:34 PM
    • Marked as answer by EdibleFibre Friday, February 20, 2015 9:31 PM
    Wednesday, February 18, 2015 2:23 PM

All replies

  • Hello, EdibleFibre.

    As virtual machines successfully PXE boots, seems it is network issue:

    Are virtual machines and physical workstations on the same subnet? If not, are DHCP options 60,66,67 configured for both scopes on DHCP?

    Can you reach from subnet, where physical workstation connected, WDS server (ping)?

    • Edited by fapw Wednesday, February 18, 2015 8:43 AM
    Wednesday, February 18, 2015 8:03 AM
  • All machines, virtual and physical, are on the same subnet and can ping the WDS/DHCP server.

    The DHCP scope option that is configured is 60 with PXEClient. 66 and 67 are absent.


    • Edited by EdibleFibre Wednesday, February 18, 2015 2:03 PM
    Wednesday, February 18, 2015 2:02 PM
  • Have you tried this (from article):

    Custom-made Option 60 – String – PXEClient
    Predefined Option 66 – IP or Hostname of the WDS Server (in our case 10.150.150.1)
    Predefined Option 67 – boot\x86\wdsnbp.com

    and this in WDS properties:

    and

    Many people remark this as solution:

    WDSUTIL /Delete-AutoAddDevices /DeviceType:ApprovedDevices


    • Edited by fapw Wednesday, February 18, 2015 2:34 PM
    • Marked as answer by EdibleFibre Friday, February 20, 2015 9:31 PM
    Wednesday, February 18, 2015 2:23 PM
  • fapw

    That got it.

    Not sure why everything says not to configure 66 and 67 when the WDS is on the DHCP server.

    Thanks.

    Friday, February 20, 2015 9:31 PM