locked
Error when Activating the SharePoint Server Publishing Infrastructure feature RRS feed

  • Question

  • Seem to be getting a strange error when trying to activate the 

    SharePoint Server Publishing Infrastructure:

    The error is:

    Error

     

    Column Limit Exceeded.

     

    There are too many columns of the specified data type. Please delete some other columns first. Note that some column types like numbers and currency use the same data type.

     

    Troubleshoot issues with Microsoft SharePoint Foundation.

     

    Correlation ID: 277c8525-6023-489c-bde8-d17dd066f8fb

     

    Date and Time: 16/02/2011 10:24:36

     

    In Event Log the error is:

    Event log message was: 'Failed to create the 'Quick Deploy Items' list.'. Exception was: 'Microsoft.SharePoint.SPException: Column Limit Exceeded.

     

    There are too many columns of the specified data type. Please delete some other columns first. Note that some column types like numbers and currency use the same data type. ---> System.Runtime.InteropServices.COMException (0x8102003A): Column Limit Exceeded.

     

    There are too many columns of the specified data type. Please delete some other columns first. Note that some column types like numbers and currency use the same data type.

       at Microsoft.SharePoint.Library.SPRequestInternalClass.AddField(String bstrUrl, String bstrListName, String bstrSchemaXml, Int32 grfAdd)

       at Microsoft.SharePoint.Library.SPRequest.AddField(String bstrUrl, String bstrListName, String bstrSchemaXml, Int32 grfAdd)

       --- End of inner exception stack trace ---

       at Microsoft.SharePoint.SPGlobal.HandleComException(COMException comEx)

       at Microsoft.SharePoint.Library.SPRequest.AddField(String bstrUrl, String bstrListName, String bstrSchemaXml, Int32 grfAdd)

       at Microsoft.SharePoint.SPFieldCollection.AddFieldAsXmlInternal(String schemaXml, Boolean addToDefaultView, SPAddFieldOptions op, Boolean isMigration, Boolean fResetCTCol)

       at Microsoft.SharePoint.SPFieldCollection.AddInternal(String strDisplayName, SPFieldType type, Boolean bRequired, Boolean bCompactName, Guid lookupListId, Guid lookupWebId, StringCollection choices)

       at Microsoft.SharePoint.SPFieldCollection.Add(String strDisplayName, SPFieldType type, Boolean bRequired, Boolean bCompactName, StringCollection choices)

       at Microsoft.SharePoint.SPFieldCollection.Add(String strDisplayName, SPFieldType type, Boolean bRequired)

       at Microsoft.SharePoint.Publishing.Internal.RootProvisioner.CreateQuickDeployItemsList()'

     

    This is not an upgrade of any kind, it was a new installation and i am in the progress of setting up the FAST Search features however without being able to activate this feature i cannot do this.

     

    Thanks

     

    • Moved by Mike Walsh FIN Wednesday, February 16, 2011 3:13 PM SP2010 questions go only to SP 2010 forums (From:SharePoint - Setup, Upgrade, Administration and Operation (pre-SharePoint 2010))
    Wednesday, February 16, 2011 10:25 AM

Answers

  • I had the same problem with a few of our sites after migrating to sharepoint 2010 and it turned out that there was a quick deploy items list present in the site when we tried to activate the feature. The list can be accessed at http://yoursharepoint/yoursite/quick%20deploy%20items where yoursite is the toplevel of your sitecollection.

    The problem was that sharepoint had somehow multiplied the fields "JobId", "ItemUrl" and "ItemType" so that it was not possible to add those fields in the process of activating the publishing feature. The Solution for me was to delete all those fields from the quick deploy items list since you cannot delete the list itself by default.

    The only way to delete the list would be to use powershell.

    $Web=Get-SPWeb http://yoursharepoint/yoursite
    $List=$Web.Lists["Quick Deploy Items"]
    $List.AllowDeletion=$True
    $List.delete()

    I haven't tried this myself though and I would recommend using $list.update() instead of $list.delete() and then to delete it using IE. 

    When the error occured in my farm I found some blog post that brought my to that solution but I cannot manage to find the blog right now.

    • Proposed as answer by Tom Debrozla Tuesday, July 26, 2011 9:32 AM
    • Unproposed as answer by Tom Debrozla Tuesday, July 26, 2011 9:32 AM
    • Proposed as answer by mcomsto Sunday, April 22, 2012 8:24 PM
    • Marked as answer by Steven AndrewsEditor Tuesday, July 3, 2012 2:34 PM
    Thursday, February 17, 2011 6:40 AM

All replies

  • Microsoft SharePoint Foundation is SharePoint 2010, so I'd expect Mike to move this to the correct forum quite soon.  (Mike Note: Soon enough?)

    In response to your question, this behaviour happens when you try to add more columns than your Windows SharePoint Services list supports. There are limits on the number of columns that you can create in a Windows SharePoint Services list. The limits are determined by the column type that you use for the list.  I'm not sure what the SharePoint 2010 ones are, but for example the SharePoint 2003 ones were as follows: -

     

    • 64 Single line of text and Choice (drop-down menu or radio buttons)
    • 31 Multiple lines of text and Choice (check boxes (allow multiple sections))
    • 32 Number and currency
    • 32 Hyperlink
    • 16 Date and time
    • 16 Lookup
    • 16 Yes/No
    • 8 Calculated
    Now, to your instance, can tell us if you've used the Quick Deploy Feature?  It looks like this is the root of your issue.

    Please check this link for how to check/turn off Quick Deploy jobs: http://technet.microsoft.com/en-us/library/cc262560.aspx.  If you've got one running, try stopping them all and reactivating the feature on your site.

     


    http://www.final-exodus.net
    • Edited by Mike Walsh FIN Wednesday, February 16, 2011 3:13 PM Mike Note added.
    Wednesday, February 16, 2011 11:25 AM
    Answerer
  • I had the same problem with a few of our sites after migrating to sharepoint 2010 and it turned out that there was a quick deploy items list present in the site when we tried to activate the feature. The list can be accessed at http://yoursharepoint/yoursite/quick%20deploy%20items where yoursite is the toplevel of your sitecollection.

    The problem was that sharepoint had somehow multiplied the fields "JobId", "ItemUrl" and "ItemType" so that it was not possible to add those fields in the process of activating the publishing feature. The Solution for me was to delete all those fields from the quick deploy items list since you cannot delete the list itself by default.

    The only way to delete the list would be to use powershell.

    $Web=Get-SPWeb http://yoursharepoint/yoursite
    $List=$Web.Lists["Quick Deploy Items"]
    $List.AllowDeletion=$True
    $List.delete()

    I haven't tried this myself though and I would recommend using $list.update() instead of $list.delete() and then to delete it using IE. 

    When the error occured in my farm I found some blog post that brought my to that solution but I cannot manage to find the blog right now.

    • Proposed as answer by Tom Debrozla Tuesday, July 26, 2011 9:32 AM
    • Unproposed as answer by Tom Debrozla Tuesday, July 26, 2011 9:32 AM
    • Proposed as answer by mcomsto Sunday, April 22, 2012 8:24 PM
    • Marked as answer by Steven AndrewsEditor Tuesday, July 3, 2012 2:34 PM
    Thursday, February 17, 2011 6:40 AM
  • Hi All

     

    when i am trying to actiuvate the publishing feature on my site . I am getting the runtime error which is

     

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

     

    I had already activated the publishing feature in site collection , i am getting this error when i am trying to activate this at site level..

     

    thanks for the help..

    Tuesday, June 28, 2011 3:52 PM
  • Hi All,

    I´ve got this error message too. Solution in my cas was:

    - User / Groups / Permission levels for this site were modified. Resetting Groups / Users / Permission Levels to default solved this.

    In my case I have deleted the SPGroup "Viewers".

    Afterwards I was been able to activate the infrastructure features successfully.

    HTH

    Wednesday, July 4, 2012 9:32 AM